summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/profiles/000-Default.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-02-06 11:16:20 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-02-06 11:16:20 +0000
commiteda08dd423ebd3160c7d5e928873fc98c4a028de (patch)
tree29f0ac015344f293c33c086f2348a7b169425054 /target/linux/mvebu/profiles/000-Default.mk
parent74338a700a09322575ada75a2edc05a9f896ef96 (diff)
downloadmaster-31e0f0ae-eda08dd423ebd3160c7d5e928873fc98c4a028de.tar.gz
master-31e0f0ae-eda08dd423ebd3160c7d5e928873fc98c4a028de.tar.bz2
master-31e0f0ae-eda08dd423ebd3160c7d5e928873fc98c4a028de.zip
mvebu: support building images for a single board
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 44290
Diffstat (limited to 'target/linux/mvebu/profiles/000-Default.mk')
-rw-r--r--target/linux/mvebu/profiles/000-Default.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/mvebu/profiles/000-Default.mk b/target/linux/mvebu/profiles/000-Default.mk
new file mode 100644
index 0000000000..981855fa3c
--- /dev/null
+++ b/target/linux/mvebu/profiles/000-Default.mk
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile (all drivers)
+ PACKAGES:= \
+ kmod-mmc kmod-mvsdio swconfig \
+ kmod-usb2 kmod-usb3 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-rtc-marvell kmod-thermal-armada \
+ kmod-gpio-button-hotplug kmod-hwmon-tmp421 \
+ kmod-hwmon-pwmfan kmod-leds-tlc59116 \
+ kmod-ledtrig-usbdev kmod-mwlwifi wpad-mini
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+
+$(eval $(call Profile,Default))