summaryrefslogtreecommitdiffstats
path: root/target/linux/octeon/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-08-04 13:54:32 +0000
committerJohn Crispin <john@openwrt.org>2013-08-04 13:54:32 +0000
commit3a2040ffee99053070cd3f0424f40f64ba6403c9 (patch)
tree1a67f8449ff8d10237125a4f2c80d61bff916dc2 /target/linux/octeon/Makefile
parent8a4726bca828860a140bef2e81cfcc653b440247 (diff)
downloadmaster-31e0f0ae-3a2040ffee99053070cd3f0424f40f64ba6403c9.tar.gz
master-31e0f0ae-3a2040ffee99053070cd3f0424f40f64ba6403c9.tar.bz2
master-31e0f0ae-3a2040ffee99053070cd3f0424f40f64ba6403c9.zip
octeon: add support for the octeon mips64 SoC
This is the SoC used be the ESR Lite made by ubnt.com Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 37684
Diffstat (limited to 'target/linux/octeon/Makefile')
-rw-r--r--target/linux/octeon/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/octeon/Makefile b/target/linux/octeon/Makefile
new file mode 100644
index 0000000000..ea005d01f6
--- /dev/null
+++ b/target/linux/octeon/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=octeon
+BOARDNAME:=Cavium Networks Octeon
+FEATURES:=squashfs jffs2 pci usb
+CFLAGS:=-Os -pipe -march=octeon -fno-caller-saves
+MAINTAINER:=John Crispin <blogic@openwrt.org>
+
+LINUX_VERSION:=3.10
+
+include $(INCLUDE_DIR)/target.mk
+
+
+define Target/Description
+ Build firmware images for Cavium Networks Octeon-based boards.
+endef
+
+$(eval $(call BuildTarget))