summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-3.18/300-introduce-oxnas-platform.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-05-21 19:32:46 +0000
committerJonas Gorski <jogo@openwrt.org>2015-05-21 19:32:46 +0000
commit76d079204df113afa9e382a43abb5e1a2135150d (patch)
tree8e472ab203e8d6a47dc2e285b3becbfca35d04c6 /target/linux/oxnas/patches-3.18/300-introduce-oxnas-platform.patch
parent072937888e133f5e97fd05a7496eaf7eeae04079 (diff)
downloadmaster-31e0f0ae-76d079204df113afa9e382a43abb5e1a2135150d.tar.gz
master-31e0f0ae-76d079204df113afa9e382a43abb5e1a2135150d.tar.bz2
master-31e0f0ae-76d079204df113afa9e382a43abb5e1a2135150d.zip
kernel: update 3.18 to 3.18.14
Changelogs: * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.12 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.13 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.14 Build tested on brcm63xx and ipq806x, runtested on brcm63xx. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 45711
Diffstat (limited to 'target/linux/oxnas/patches-3.18/300-introduce-oxnas-platform.patch')
-rw-r--r--target/linux/oxnas/patches-3.18/300-introduce-oxnas-platform.patch30
1 files changed, 10 insertions, 20 deletions
diff --git a/target/linux/oxnas/patches-3.18/300-introduce-oxnas-platform.patch b/target/linux/oxnas/patches-3.18/300-introduce-oxnas-platform.patch
index 17ec83b63f..5724263d3f 100644
--- a/target/linux/oxnas/patches-3.18/300-introduce-oxnas-platform.patch
+++ b/target/linux/oxnas/patches-3.18/300-introduce-oxnas-platform.patch
@@ -1,7 +1,5 @@
-Index: linux-3.18-rc4/arch/arm/Kconfig
-===================================================================
---- linux-3.18-rc4.orig/arch/arm/Kconfig
-+++ linux-3.18-rc4/arch/arm/Kconfig
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
@@ -369,6 +369,17 @@ config ARCH_VERSATILE
help
This enables support for ARM Ltd Versatile board.
@@ -29,10 +27,8 @@ Index: linux-3.18-rc4/arch/arm/Kconfig
source "arch/arm/mach-picoxcell/Kconfig"
source "arch/arm/mach-pxa/Kconfig"
-Index: linux-3.18-rc4/arch/arm/Makefile
-===================================================================
---- linux-3.18-rc4.orig/arch/arm/Makefile
-+++ linux-3.18-rc4/arch/arm/Makefile
+--- a/arch/arm/Makefile
++++ b/arch/arm/Makefile
@@ -187,6 +187,7 @@ machine-$(CONFIG_ARCH_NSPIRE) += nspire
machine-$(CONFIG_ARCH_OMAP1) += omap1
machine-$(CONFIG_ARCH_OMAP2PLUS) += omap2
@@ -41,10 +37,8 @@ Index: linux-3.18-rc4/arch/arm/Makefile
machine-$(CONFIG_ARCH_PICOXCELL) += picoxcell
machine-$(CONFIG_ARCH_PXA) += pxa
machine-$(CONFIG_ARCH_QCOM) += qcom
-Index: linux-3.18-rc4/arch/arm/boot/dts/Makefile
-===================================================================
---- linux-3.18-rc4.orig/arch/arm/boot/dts/Makefile
-+++ linux-3.18-rc4/arch/arm/boot/dts/Makefile
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
@@ -352,6 +352,7 @@ dtb-$(CONFIG_ARCH_ORION5X) += orion5x-la
orion5x-lacie-ethernet-disk-mini-v2.dtb \
orion5x-maxtor-shared-storage-2.dtb \
@@ -53,10 +47,8 @@ Index: linux-3.18-rc4/arch/arm/boot/dts/Makefile
dtb-$(CONFIG_ARCH_PRIMA2) += prima2-evb.dtb
dtb-$(CONFIG_ARCH_QCOM) += \
qcom-apq8064-cm-qs600.dtb \
-Index: linux-3.18-rc4/arch/arm/tools/mach-types
-===================================================================
---- linux-3.18-rc4.orig/arch/arm/tools/mach-types
-+++ linux-3.18-rc4/arch/arm/tools/mach-types
+--- a/arch/arm/tools/mach-types
++++ b/arch/arm/tools/mach-types
@@ -228,6 +228,7 @@ edb9302a MACH_EDB9302A EDB9302A 1127
edb9307a MACH_EDB9307A EDB9307A 1128
omap_3430sdp MACH_OMAP_3430SDP OMAP_3430SDP 1138
@@ -65,10 +57,8 @@ Index: linux-3.18-rc4/arch/arm/tools/mach-types
micro9m MACH_MICRO9M MICRO9M 1169
bug MACH_BUG BUG 1179
at91sam9263ek MACH_AT91SAM9263EK AT91SAM9263EK 1202
-Index: linux-3.18-rc4/drivers/clk/Makefile
-===================================================================
---- linux-3.18-rc4.orig/drivers/clk/Makefile
-+++ linux-3.18-rc4/drivers/clk/Makefile
+--- a/drivers/clk/Makefile
++++ b/drivers/clk/Makefile
@@ -29,6 +29,7 @@ obj-$(CONFIG_COMMON_CLK_MAX77802) += clk
obj-$(CONFIG_ARCH_MOXART) += clk-moxart.o
obj-$(CONFIG_ARCH_NOMADIK) += clk-nomadik.o