summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.1/340-oxnas-pcie.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-08-17 06:03:57 +0000
committerJohn Crispin <john@openwrt.org>2015-08-17 06:03:57 +0000
commit7261fde797e1b63f032af4e7b5ac9eebc66c4a31 (patch)
treec47b88867fa5c873a7839957200555fab041cd65 /target/linux/oxnas/patches-4.1/340-oxnas-pcie.patch
parentf32116987f56a4441848e6970beb361b422729e7 (diff)
downloadmaster-31e0f0ae-7261fde797e1b63f032af4e7b5ac9eebc66c4a31.tar.gz
master-31e0f0ae-7261fde797e1b63f032af4e7b5ac9eebc66c4a31.tar.bz2
master-31e0f0ae-7261fde797e1b63f032af4e7b5ac9eebc66c4a31.zip
oxnas: prepare for kernel 4.1
Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 46636
Diffstat (limited to 'target/linux/oxnas/patches-4.1/340-oxnas-pcie.patch')
-rw-r--r--target/linux/oxnas/patches-4.1/340-oxnas-pcie.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.1/340-oxnas-pcie.patch b/target/linux/oxnas/patches-4.1/340-oxnas-pcie.patch
new file mode 100644
index 0000000000..ec9dc941a3
--- /dev/null
+++ b/target/linux/oxnas/patches-4.1/340-oxnas-pcie.patch
@@ -0,0 +1,22 @@
+--- a/drivers/pci/host/Kconfig
++++ b/drivers/pci/host/Kconfig
+@@ -125,4 +125,9 @@ config PCIE_IPROC_PLATFORM
+ Say Y here if you want to use the Broadcom iProc PCIe controller
+ through the generic platform bus interface
+
++config PCI_OXNAS
++ bool "PLX Oxnas PCIe controller"
++ depends on ARCH_OXNAS
++ select PCIEPORTBUS
++
+ endmenu
+--- a/drivers/pci/host/Makefile
++++ b/drivers/pci/host/Makefile
+@@ -3,6 +3,7 @@ obj-$(CONFIG_PCI_DRA7XX) += pci-dra7xx.o
+ obj-$(CONFIG_PCI_EXYNOS) += pci-exynos.o
+ obj-$(CONFIG_PCI_IMX6) += pci-imx6.o
+ obj-$(CONFIG_PCI_MVEBU) += pci-mvebu.o
++obj-$(CONFIG_PCI_OXNAS) += pcie-oxnas.o
+ obj-$(CONFIG_PCI_TEGRA) += pci-tegra.o
+ obj-$(CONFIG_PCI_RCAR_GEN2) += pci-rcar-gen2.o
+ obj-$(CONFIG_PCI_RCAR_GEN2_PCIE) += pcie-rcar.o