summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.1/340-oxnas-pcie.patch
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2016-07-18 18:32:48 +0200
committerDaniel Golle <daniel@makrotopia.org>2016-07-18 18:35:32 +0200
commitc5ec5e1f7f33a18ea81d3d9254c5b49bbdfd5e16 (patch)
treed3f814a4a85f72d5093ba49c3518c8e7e46e9f33 /target/linux/oxnas/patches-4.1/340-oxnas-pcie.patch
parent56f686b7107b17341e6357e31435237e6fb1bb0c (diff)
downloadmaster-31e0f0ae-c5ec5e1f7f33a18ea81d3d9254c5b49bbdfd5e16.tar.gz
master-31e0f0ae-c5ec5e1f7f33a18ea81d3d9254c5b49bbdfd5e16.tar.bz2
master-31e0f0ae-c5ec5e1f7f33a18ea81d3d9254c5b49bbdfd5e16.zip
oxnas: revert to kernel 4.1
A bug resulting in the NAND not being detected by newer kernels has kept me sleepless for months and yet I wasn't able to discover the cause. Bring back patches and files for 4.1 until this has been resolved. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/oxnas/patches-4.1/340-oxnas-pcie.patch')
-rw-r--r--target/linux/oxnas/patches-4.1/340-oxnas-pcie.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.1/340-oxnas-pcie.patch b/target/linux/oxnas/patches-4.1/340-oxnas-pcie.patch
new file mode 100644
index 0000000000..ec9dc941a3
--- /dev/null
+++ b/target/linux/oxnas/patches-4.1/340-oxnas-pcie.patch
@@ -0,0 +1,22 @@
+--- a/drivers/pci/host/Kconfig
++++ b/drivers/pci/host/Kconfig
+@@ -125,4 +125,9 @@ config PCIE_IPROC_PLATFORM
+ Say Y here if you want to use the Broadcom iProc PCIe controller
+ through the generic platform bus interface
+
++config PCI_OXNAS
++ bool "PLX Oxnas PCIe controller"
++ depends on ARCH_OXNAS
++ select PCIEPORTBUS
++
+ endmenu
+--- a/drivers/pci/host/Makefile
++++ b/drivers/pci/host/Makefile
+@@ -3,6 +3,7 @@ obj-$(CONFIG_PCI_DRA7XX) += pci-dra7xx.o
+ obj-$(CONFIG_PCI_EXYNOS) += pci-exynos.o
+ obj-$(CONFIG_PCI_IMX6) += pci-imx6.o
+ obj-$(CONFIG_PCI_MVEBU) += pci-mvebu.o
++obj-$(CONFIG_PCI_OXNAS) += pcie-oxnas.o
+ obj-$(CONFIG_PCI_TEGRA) += pci-tegra.o
+ obj-$(CONFIG_PCI_RCAR_GEN2) += pci-rcar-gen2.o
+ obj-$(CONFIG_PCI_RCAR_GEN2_PCIE) += pcie-rcar.o