summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.1/350-oxnas-reset.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-08-17 06:03:57 +0000
committerJohn Crispin <john@openwrt.org>2015-08-17 06:03:57 +0000
commit7261fde797e1b63f032af4e7b5ac9eebc66c4a31 (patch)
treec47b88867fa5c873a7839957200555fab041cd65 /target/linux/oxnas/patches-4.1/350-oxnas-reset.patch
parentf32116987f56a4441848e6970beb361b422729e7 (diff)
downloadmaster-31e0f0ae-7261fde797e1b63f032af4e7b5ac9eebc66c4a31.tar.gz
master-31e0f0ae-7261fde797e1b63f032af4e7b5ac9eebc66c4a31.tar.bz2
master-31e0f0ae-7261fde797e1b63f032af4e7b5ac9eebc66c4a31.zip
oxnas: prepare for kernel 4.1
Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 46636
Diffstat (limited to 'target/linux/oxnas/patches-4.1/350-oxnas-reset.patch')
-rw-r--r--target/linux/oxnas/patches-4.1/350-oxnas-reset.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.1/350-oxnas-reset.patch b/target/linux/oxnas/patches-4.1/350-oxnas-reset.patch
new file mode 100644
index 0000000000..1cecd28dc7
--- /dev/null
+++ b/target/linux/oxnas/patches-4.1/350-oxnas-reset.patch
@@ -0,0 +1,20 @@
+--- a/drivers/reset/Kconfig
++++ b/drivers/reset/Kconfig
+@@ -12,4 +12,9 @@ menuconfig RESET_CONTROLLER
+
+ If unsure, say no.
+
++config RESET_CONTROLLER_OXNAS
++ bool
++ select RESET_CONTROLLER
++
+ source "drivers/reset/sti/Kconfig"
++
+--- a/drivers/reset/Makefile
++++ b/drivers/reset/Makefile
+@@ -1,4 +1,5 @@
+ obj-$(CONFIG_RESET_CONTROLLER) += core.o
++obj-$(CONFIG_RESET_CONTROLLER_OXNAS) += reset-ox820.o
+ obj-$(CONFIG_ARCH_SOCFPGA) += reset-socfpga.o
+ obj-$(CONFIG_ARCH_BERLIN) += reset-berlin.o
+ obj-$(CONFIG_ARCH_SUNXI) += reset-sunxi.o