summaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.4/500-oxnas-sata.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-18 23:34:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-18 23:34:59 +0000
commit89d37aaa5c757ef70c75fd3aa2bc5b720c8ae77f (patch)
tree848a9021c421e17836fcedad1b9154e9e7729556 /target/linux/oxnas/patches-4.4/500-oxnas-sata.patch
parentcee6c07cf32302ad71cc8c540f997b552a3ba4aa (diff)
downloadmaster-31e0f0ae-89d37aaa5c757ef70c75fd3aa2bc5b720c8ae77f.tar.gz
master-31e0f0ae-89d37aaa5c757ef70c75fd3aa2bc5b720c8ae77f.tar.bz2
master-31e0f0ae-89d37aaa5c757ef70c75fd3aa2bc5b720c8ae77f.zip
oxnas: add patches and config for Linux 4.4
Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 48339
Diffstat (limited to 'target/linux/oxnas/patches-4.4/500-oxnas-sata.patch')
-rw-r--r--target/linux/oxnas/patches-4.4/500-oxnas-sata.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.4/500-oxnas-sata.patch b/target/linux/oxnas/patches-4.4/500-oxnas-sata.patch
new file mode 100644
index 0000000000..3891dc1bc2
--- /dev/null
+++ b/target/linux/oxnas/patches-4.4/500-oxnas-sata.patch
@@ -0,0 +1,26 @@
+--- a/drivers/ata/Kconfig
++++ b/drivers/ata/Kconfig
+@@ -429,6 +429,13 @@ config SATA_VITESSE
+
+ If unsure, say N.
+
++config SATA_OXNAS
++ tristate "PLXTECH NAS782X SATA support"
++ help
++ This option enables support for Nas782x Serial ATA controller.
++
++ If unsure, say N.
++
+ comment "PATA SFF controllers with BMDMA"
+
+ config PATA_ALI
+--- a/drivers/ata/Makefile
++++ b/drivers/ata/Makefile
+@@ -40,6 +40,7 @@ obj-$(CONFIG_SATA_SVW) += sata_svw.o
+ obj-$(CONFIG_SATA_ULI) += sata_uli.o
+ obj-$(CONFIG_SATA_VIA) += sata_via.o
+ obj-$(CONFIG_SATA_VITESSE) += sata_vsc.o
++obj-$(CONFIG_SATA_OXNAS) += sata_oxnas.o
+
+ # SFF PATA w/ BMDMA
+ obj-$(CONFIG_PATA_ALI) += pata_ali.o