summaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-01-29 00:58:46 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-01-29 00:58:46 +0000
commit2f2ae0205c3377c77e9b213e6e53565557539b2b (patch)
treef1cbed37b6d8938056e3ba64f1607e8b9aaf977a /target/linux/ppc40x/Makefile
parent36984a4cb5c3de368a4af36ea9ab890e77fd4415 (diff)
downloadmaster-31e0f0ae-2f2ae0205c3377c77e9b213e6e53565557539b2b.tar.gz
master-31e0f0ae-2f2ae0205c3377c77e9b213e6e53565557539b2b.tar.bz2
master-31e0f0ae-2f2ae0205c3377c77e9b213e6e53565557539b2b.zip
add basic support for the AMCC PPC405EX Kilauea evaluation board
SVN-Revision: 10303
Diffstat (limited to 'target/linux/ppc40x/Makefile')
-rw-r--r--target/linux/ppc40x/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ppc40x/Makefile b/target/linux/ppc40x/Makefile
new file mode 100644
index 0000000000..cd64ea3f65
--- /dev/null
+++ b/target/linux/ppc40x/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=ppc40x
+BOARDNAME:=AMCC Kilauea
+FEATURES:=squashfs
+
+LINUX_VERSION:=2.6.24
+LINUX_KARCH:=powerpc
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build firmware images for the AMCC Kilauea evaluation board
+endef
+
+$(eval $(call BuildTarget))