summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-03-16 09:26:48 +0000
committerJohn Crispin <john@openwrt.org>2016-03-16 09:26:48 +0000
commit99414dbcf1901a8f362e62febe562dacd4595c8e (patch)
tree1927d20fe846d8453e5501087f3a6643b7d438aa /target/linux/ramips/image/Makefile
parent553c1b793f6de84e8ed545535f1ee54c4c4c0581 (diff)
downloadmaster-31e0f0ae-99414dbcf1901a8f362e62febe562dacd4595c8e.tar.gz
master-31e0f0ae-99414dbcf1901a8f362e62febe562dacd4595c8e.tar.bz2
master-31e0f0ae-99414dbcf1901a8f362e62febe562dacd4595c8e.zip
ramips: Add support for Xiaomi MiWiFi Nano
Xiaomi MiWiFi Nano is based on Mediatek MT7628 with 64MB ram 16MB flash Signed-off-by: Noble Pepper <openwrtmail@noblepepper.com> v3 includes changes suggested by L. D. Pinney & Karl Palsson- Eliminate en25q64 (4MB) flash chip Alphabetization Remove hyphen in model Rename profile from miwifinano.mk to xiaomi.mk Add gpios that are attached to leds SVN-Revision: 49024
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index bc42d148ad..45cb22b09c 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -1148,6 +1148,7 @@ endef
# MT7628 Profiles
#
+Image/Build/Profile/MIWIFI-NANO=$(call BuildFirmware/Default16M/$(1),$(1),miwifi-nano,MIWIFI-NANO)
Image/Build/Profile/MT7628=$(call BuildFirmware/Default4M/$(1),$(1),mt7628,MT7628)
Image/Build/Profile/WRTNODE2P=$(call BuildFirmware/Default16M/$(1),$(1),wrtnode2p,WRTNODE2P)
@@ -1156,6 +1157,9 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/MT7628,$(1))
$(call Image/Build/Profile/WRTNODE2P,$(1))
endef
+define Image/Build/Profile/MiwifiNano
+ $(call Image/Build/Profile/MIWIFI-NANO,$(1))
+endef
endif