summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7688/profiles/01-mediatek.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-10-19 10:07:38 +0000
committerJohn Crispin <john@openwrt.org>2015-10-19 10:07:38 +0000
commit51dd991d3957a33f102c9887da379263599c395f (patch)
treefb3e9fdd2edcc6c2f42a385f7196b28fd6370f3c /target/linux/ramips/mt7688/profiles/01-mediatek.mk
parentb792ea7ac045922ff287ed95c1a4d5961640f19f (diff)
downloadmaster-31e0f0ae-51dd991d3957a33f102c9887da379263599c395f.tar.gz
master-31e0f0ae-51dd991d3957a33f102c9887da379263599c395f.tar.bz2
master-31e0f0ae-51dd991d3957a33f102c9887da379263599c395f.zip
ramips: add LinkIt Smart7688 support
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 47203
Diffstat (limited to 'target/linux/ramips/mt7688/profiles/01-mediatek.mk')
-rw-r--r--target/linux/ramips/mt7688/profiles/01-mediatek.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7688/profiles/01-mediatek.mk b/target/linux/ramips/mt7688/profiles/01-mediatek.mk
index 02190dd3ab..0e24e0686c 100644
--- a/target/linux/ramips/mt7688/profiles/01-mediatek.mk
+++ b/target/linux/ramips/mt7688/profiles/01-mediatek.mk
@@ -16,3 +16,15 @@ define Profile/mt7688/Description
Default package set compatible with most boards.
endef
$(eval $(call Profile,mt7688))
+
+define Profile/LinkIt7688
+ NAME:=LinkIt7688
+ PACKAGES:=\
+ kmod-usb-core kmod-usb2 kmod-usb-ohci \
+ uboot-envtools kmod-ledtrig-netdev
+endef
+
+define Profile/LinkIt7688/Description
+ Default package set compatible with LinkIt Smart7688 dev board.
+endef
+$(eval $(call Profile,LinkIt7688))