summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.18/0038-USB-add-OHCI-EHCI-OF-binding.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-09 12:13:55 +0000
committerJohn Crispin <john@openwrt.org>2015-02-09 12:13:55 +0000
commit654bc380ec549e3cdcc2c286ef7d67fea9509609 (patch)
treef25bfc6c0b5a8a9d50c13d0b9df290f25db9112a /target/linux/ramips/patches-3.18/0038-USB-add-OHCI-EHCI-OF-binding.patch
parent826b461427fa2abe634e652a05dfc86fc8a6c609 (diff)
downloadmaster-31e0f0ae-654bc380ec549e3cdcc2c286ef7d67fea9509609.tar.gz
master-31e0f0ae-654bc380ec549e3cdcc2c286ef7d67fea9509609.tar.bz2
master-31e0f0ae-654bc380ec549e3cdcc2c286ef7d67fea9509609.zip
ralink: add 3.18 support
keep default as 3.14, mt7621 gic need to be ported to 3.18 Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 44349
Diffstat (limited to 'target/linux/ramips/patches-3.18/0038-USB-add-OHCI-EHCI-OF-binding.patch')
-rw-r--r--target/linux/ramips/patches-3.18/0038-USB-add-OHCI-EHCI-OF-binding.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-3.18/0038-USB-add-OHCI-EHCI-OF-binding.patch b/target/linux/ramips/patches-3.18/0038-USB-add-OHCI-EHCI-OF-binding.patch
new file mode 100644
index 0000000000..3012c1c9b5
--- /dev/null
+++ b/target/linux/ramips/patches-3.18/0038-USB-add-OHCI-EHCI-OF-binding.patch
@@ -0,0 +1,34 @@
+From ffb27de4760595c356ef619c97f25722c8db28e7 Mon Sep 17 00:00:00 2001
+From: John Crispin <blogic@openwrt.org>
+Date: Sun, 27 Jul 2014 09:49:07 +0100
+Subject: [PATCH 38/57] USB: add OHCI/EHCI OF binding
+
+based on f3bc64d6d1f21c1b92d75f233a37b75d77af6963
+
+Signed-off-by: John Crispin <blogic@openwrt.org>
+---
+ drivers/usb/Makefile | 3 ++-
+ drivers/usb/host/ehci-platform.c | 21 +++++++++++++++++----
+ drivers/usb/host/ohci-platform.c | 37 +++++++++++++++++++++++++++++++------
+ 3 files changed, 50 insertions(+), 11 deletions(-)
+
+--- a/drivers/usb/host/ehci-platform.c
++++ b/drivers/usb/host/ehci-platform.c
+@@ -359,6 +373,7 @@ static int ehci_platform_resume(struct d
+ static const struct of_device_id vt8500_ehci_ids[] = {
+ { .compatible = "via,vt8500-ehci", },
+ { .compatible = "wm,prizm-ehci", },
++ { .compatible = "ralink,rt3xxx-ehci", },
+ { .compatible = "generic-ehci", },
+ {}
+ };
+--- a/drivers/usb/host/ohci-platform.c
++++ b/drivers/usb/host/ohci-platform.c
+@@ -342,6 +358,7 @@ static int ohci_platform_resume(struct d
+ #endif /* CONFIG_PM */
+
+ static const struct of_device_id ohci_platform_ids[] = {
++ { .compatible = "ralink,rt3xxx-ohci", },
+ { .compatible = "generic-ohci", },
+ { }
+ };