summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.3/105-usb_dwc_otg.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-04-21 12:30:50 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-04-21 12:30:50 +0000
commit5c325b0057c3ae3447c396f0f27c8c1628321a4b (patch)
treeede9e3cdc6d26d484bbed214c2ee82ac63b6e014 /target/linux/ramips/patches-3.3/105-usb_dwc_otg.patch
parent7f902c962b3314665cbccf013e3bac599d514581 (diff)
downloadmaster-31e0f0ae-5c325b0057c3ae3447c396f0f27c8c1628321a4b.tar.gz
master-31e0f0ae-5c325b0057c3ae3447c396f0f27c8c1628321a4b.tar.bz2
master-31e0f0ae-5c325b0057c3ae3447c396f0f27c8c1628321a4b.zip
ramips: add support for 3.3
SVN-Revision: 31403
Diffstat (limited to 'target/linux/ramips/patches-3.3/105-usb_dwc_otg.patch')
-rw-r--r--target/linux/ramips/patches-3.3/105-usb_dwc_otg.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-3.3/105-usb_dwc_otg.patch b/target/linux/ramips/patches-3.3/105-usb_dwc_otg.patch
new file mode 100644
index 0000000000..1d9ecd920b
--- /dev/null
+++ b/target/linux/ramips/patches-3.3/105-usb_dwc_otg.patch
@@ -0,0 +1,20 @@
+--- a/drivers/usb/Kconfig
++++ b/drivers/usb/Kconfig
+@@ -182,4 +182,6 @@ source "drivers/usb/gadget/Kconfig"
+
+ source "drivers/usb/otg/Kconfig"
+
++source "drivers/usb/dwc_otg/Kconfig"
++
+ endif # USB_SUPPORT
+--- a/drivers/usb/Makefile
++++ b/drivers/usb/Makefile
+@@ -51,6 +51,8 @@ obj-$(CONFIG_EARLY_PRINTK_DBGP) += early
+ obj-$(CONFIG_USB_ATM) += atm/
+ obj-$(CONFIG_USB_SPEEDTOUCH) += atm/
+
++obj-$(CONFIG_DWC_OTG) += dwc_otg/
++
+ obj-$(CONFIG_USB_MUSB_HDRC) += musb/
+ obj-$(CONFIG_USB_RENESAS_USBHS) += renesas_usbhs/
+ obj-$(CONFIG_USB_GADGET) += gadget/