summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-4.3/0029-phy-usb-add-ralink-phy.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-02 14:48:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-02 14:48:27 +0000
commitc69ffda546522ae67544ad717a45abbc2ca3527f (patch)
treefb2de31fd6d40b87d35e63d5b8e01a03e9f0bbf8 /target/linux/ramips/patches-4.3/0029-phy-usb-add-ralink-phy.patch
parent140be9f1a5915e952722813e60716a257d622f74 (diff)
downloadmaster-31e0f0ae-c69ffda546522ae67544ad717a45abbc2ca3527f.tar.gz
master-31e0f0ae-c69ffda546522ae67544ad717a45abbc2ca3527f.tar.bz2
master-31e0f0ae-c69ffda546522ae67544ad717a45abbc2ca3527f.zip
ramips: clean up and refresh kernel patches
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48070
Diffstat (limited to 'target/linux/ramips/patches-4.3/0029-phy-usb-add-ralink-phy.patch')
-rw-r--r--target/linux/ramips/patches-4.3/0029-phy-usb-add-ralink-phy.patch12
1 files changed, 1 insertions, 11 deletions
diff --git a/target/linux/ramips/patches-4.3/0029-phy-usb-add-ralink-phy.patch b/target/linux/ramips/patches-4.3/0029-phy-usb-add-ralink-phy.patch
index 6bc9d1f7ea..8534da3439 100644
--- a/target/linux/ramips/patches-4.3/0029-phy-usb-add-ralink-phy.patch
+++ b/target/linux/ramips/patches-4.3/0029-phy-usb-add-ralink-phy.patch
@@ -11,8 +11,6 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
3 files changed, 181 insertions(+)
create mode 100644 drivers/phy/phy-ralink-usb.c
-diff --git a/drivers/phy/Kconfig b/drivers/phy/Kconfig
-index 47da573..96ef184 100644
--- a/drivers/phy/Kconfig
+++ b/drivers/phy/Kconfig
@@ -331,6 +331,11 @@ config PHY_XGENE
@@ -27,18 +25,13 @@ index 47da573..96ef184 100644
config PHY_STIH407_USB
tristate "STMicroelectronics USB2 picoPHY driver for STiH407 family"
depends on RESET_CONTROLLER
-diff --git a/drivers/phy/Makefile b/drivers/phy/Makefile
-index a5b18c1..8dbf6cc 100644
--- a/drivers/phy/Makefile
+++ b/drivers/phy/Makefile
-@@ -46,3 +46,4 @@ obj-$(CONFIG_PHY_QCOM_UFS) += phy-qcom-ufs-qmp-14nm.o
+@@ -46,3 +46,4 @@ obj-$(CONFIG_PHY_QCOM_UFS) += phy-qcom-
obj-$(CONFIG_PHY_TUSB1210) += phy-tusb1210.o
obj-$(CONFIG_PHY_BRCMSTB_SATA) += phy-brcmstb-sata.o
obj-$(CONFIG_PHY_PISTACHIO_USB) += phy-pistachio-usb.o
+obj-$(CONFIG_PHY_RALINK_USB) += phy-ralink-usb.o
-diff --git a/drivers/phy/phy-ralink-usb.c b/drivers/phy/phy-ralink-usb.c
-new file mode 100644
-index 0000000..6c74954
--- /dev/null
+++ b/drivers/phy/phy-ralink-usb.c
@@ -0,0 +1,175 @@
@@ -217,6 +210,3 @@ index 0000000..6c74954
+MODULE_DESCRIPTION("Ralink USB phy driver");
+MODULE_AUTHOR("John Crispin <blogic@openwrt.org>");
+MODULE_LICENSE("GPL v2");
---
-1.7.10.4
-