summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles/broadway.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-12-10 14:13:01 +0000
committerJohn Crispin <john@openwrt.org>2012-12-10 14:13:01 +0000
commitc2ae0ec02a548d47076a2439706ffccdc49095bf (patch)
tree474ce9a13c8dda77ae2235286bc31cc845df9627 /target/linux/ramips/rt305x/profiles/broadway.mk
parentcb9c63048dbe8f50ec6cbda1cf3a9a6e26976b34 (diff)
downloadmaster-31e0f0ae-c2ae0ec02a548d47076a2439706ffccdc49095bf.tar.gz
master-31e0f0ae-c2ae0ec02a548d47076a2439706ffccdc49095bf.tar.bz2
master-31e0f0ae-c2ae0ec02a548d47076a2439706ffccdc49095bf.zip
add support for Hauppauge Broadway
This patch introduces OpenWRT support for the base Hauppauge/PCTV Broadway platform. It doesn't deal with the TV tuner or transcoder at this point, but the core functionality is working (Ethernet, wireless, USB, buttons, LEDs, etc). Signed-off-by: Devin Heitmueller <dheitmueller@kernellabs.com> SVN-Revision: 34595
Diffstat (limited to 'target/linux/ramips/rt305x/profiles/broadway.mk')
-rw-r--r--target/linux/ramips/rt305x/profiles/broadway.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/broadway.mk b/target/linux/ramips/rt305x/profiles/broadway.mk
new file mode 100644
index 0000000000..8e994bdb8c
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/broadway.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/BROADWAY
+ NAME:=Hauppauge Broadway
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-rt305x-dwc_otg \
+ kmod-ledtrig-usbdev restorefactory
+endef
+
+define Profile/BROADWAY/Description
+ Package set for Hauppauge Broadway
+endef
+
+$(eval $(call Profile,BROADWAY))