summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-06-10 08:24:56 +0000
committerJohn Crispin <john@openwrt.org>2013-06-10 08:24:56 +0000
commitfc9532aeaaa73c49e50f1052f210adfda0d0c3ed (patch)
tree530d19b4add55fc19166781ca0c99fe8eefc3443 /target/linux/ramips/rt305x
parent30786d2dd0e0063b56ba5e616e868f4e6775eaad (diff)
downloadmaster-31e0f0ae-fc9532aeaaa73c49e50f1052f210adfda0d0c3ed.tar.gz
master-31e0f0ae-fc9532aeaaa73c49e50f1052f210adfda0d0c3ed.tar.bz2
master-31e0f0ae-fc9532aeaaa73c49e50f1052f210adfda0d0c3ed.zip
ramips: add HAME MPR-A2 support
This patch adds support for HAME MPR-A2 router using a DTS file. The platform is Ralink RT5350. http://wiki.openwrt.org/toh/hame/mpr-a2 Signed-off-by: Dmitry Shmygov <shmygov@rambler.ru> SVN-Revision: 36898
Diffstat (limited to 'target/linux/ramips/rt305x')
-rw-r--r--target/linux/ramips/rt305x/profiles/hame.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/hame.mk b/target/linux/ramips/rt305x/profiles/hame.mk
new file mode 100644
index 0000000000..1a85be7ba3
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/hame.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MPRA2
+ NAME:=HAME MPR-A2
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-netdev kmod-ledtrig-timer \
+ kmod-usb-acm kmod-usb-net kmod-usb-net-asix kmod-usb-net-rndis kmod-usb-serial kmod-usb-serial-option \
+ usb-modeswitch usb-modeswitch-data comgt
+endef
+
+define Profile/MPRA2/Description
+ Package set for HAME MPR-A2 board
+endef
+
+$(eval $(call Profile,MPRA2))
+