summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-08-09 11:09:52 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2015-08-09 11:09:52 +0000
commit0b8643af4fa7eebd55b63d6d547f85da1409f83d (patch)
tree4089a6861f684c95f6702412fc45b7d46a8fb46e /target/linux/ramips
parent3e52c8c35706f9cb7fa9dfb8cd4cbbaebb4d5fc7 (diff)
downloadmaster-31e0f0ae-0b8643af4fa7eebd55b63d6d547f85da1409f83d.tar.gz
master-31e0f0ae-0b8643af4fa7eebd55b63d6d547f85da1409f83d.tar.bz2
master-31e0f0ae-0b8643af4fa7eebd55b63d6d547f85da1409f83d.zip
kernel: update 3.18 to 3.18.20
Changelog: * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.20 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 46570
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/patches-3.18/0026-MIPS-ralink-add-mt7628an-support.patch8
-rw-r--r--target/linux/ramips/patches-3.18/0052-i2c-MIPS-adds-ralink-I2C-driver.patch4
-rw-r--r--target/linux/ramips/patches-3.18/0053-mmc-MIPS-ralink-add-sdhci-for-mt7620a-SoC.patch2
-rw-r--r--target/linux/ramips/patches-3.18/0060-soc_type.patch12
-rw-r--r--target/linux/ramips/patches-3.18/999-non-pci-mt7620.patch2
5 files changed, 14 insertions, 14 deletions
diff --git a/target/linux/ramips/patches-3.18/0026-MIPS-ralink-add-mt7628an-support.patch b/target/linux/ramips/patches-3.18/0026-MIPS-ralink-add-mt7628an-support.patch
index c622a12ea7..c5c5d1a446 100644
--- a/target/linux/ramips/patches-3.18/0026-MIPS-ralink-add-mt7628an-support.patch
+++ b/target/linux/ramips/patches-3.18/0026-MIPS-ralink-add-mt7628an-support.patch
@@ -264,7 +264,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
/*
* When the CPU goes into sleep mode, the BUS clock will be too low for
* USB to function properly
-@@ -367,6 +500,52 @@ void __init ralink_of_remap(void)
+@@ -367,6 +502,52 @@ void __init ralink_of_remap(void)
panic("Failed to remap core resources");
}
@@ -317,7 +317,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
void prom_soc_init(struct ralink_soc_info *soc_info)
{
void __iomem *sysc = (void __iomem *) KSEG1ADDR(MT7620_SYSC_BASE);
-@@ -384,18 +563,25 @@ void prom_soc_init(struct ralink_soc_inf
+@@ -384,18 +565,25 @@ void prom_soc_init(struct ralink_soc_inf
rev = __raw_readl(sysc + SYSC_REG_CHIP_REV);
bga = (rev >> CHIP_REV_PKG_SHIFT) & CHIP_REV_PKG_MASK;
@@ -353,7 +353,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
}
snprintf(soc_info->sys_type, RAMIPS_SYS_TYPE_LEN,
-@@ -407,28 +593,11 @@ void prom_soc_init(struct ralink_soc_inf
+@@ -407,28 +595,11 @@ void prom_soc_init(struct ralink_soc_inf
cfg0 = __raw_readl(sysc + SYSC_REG_SYSTEM_CONFIG0);
dram_type = (cfg0 >> SYSCFG0_DRAM_TYPE_SHIFT) & SYSCFG0_DRAM_TYPE_MASK;
@@ -386,7 +386,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
pmu0 = __raw_readl(sysc + PMU0_CFG);
pmu1 = __raw_readl(sysc + PMU1_CFG);
-@@ -437,4 +606,9 @@ void prom_soc_init(struct ralink_soc_inf
+@@ -437,4 +608,9 @@ void prom_soc_init(struct ralink_soc_inf
(pmu0 & PMU_SW_SET) ? ("sw") : ("hw"));
pr_info("Digital PMU set to %s control\n",
(pmu1 & DIG_SW_SEL) ? ("sw") : ("hw"));
diff --git a/target/linux/ramips/patches-3.18/0052-i2c-MIPS-adds-ralink-I2C-driver.patch b/target/linux/ramips/patches-3.18/0052-i2c-MIPS-adds-ralink-I2C-driver.patch
index 9c2538879c..8ed061070a 100644
--- a/target/linux/ramips/patches-3.18/0052-i2c-MIPS-adds-ralink-I2C-driver.patch
+++ b/target/linux/ramips/patches-3.18/0052-i2c-MIPS-adds-ralink-I2C-driver.patch
@@ -45,7 +45,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+};
--- a/drivers/i2c/busses/Kconfig
+++ b/drivers/i2c/busses/Kconfig
-@@ -710,6 +710,10 @@
+@@ -710,6 +710,10 @@ config I2C_RK3X
This driver can also be built as a module. If so, the module will
be called i2c-rk3x.
@@ -58,7 +58,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
help
--- a/drivers/i2c/busses/Makefile
+++ b/drivers/i2c/busses/Makefile
-@@ -66,6 +66,7 @@
+@@ -66,6 +66,7 @@ obj-$(CONFIG_I2C_PNX) += i2c-pnx.o
obj-$(CONFIG_I2C_PUV3) += i2c-puv3.o
obj-$(CONFIG_I2C_PXA) += i2c-pxa.o
obj-$(CONFIG_I2C_PXA_PCI) += i2c-pxa-pci.o
diff --git a/target/linux/ramips/patches-3.18/0053-mmc-MIPS-ralink-add-sdhci-for-mt7620a-SoC.patch b/target/linux/ramips/patches-3.18/0053-mmc-MIPS-ralink-add-sdhci-for-mt7620a-SoC.patch
index e8086b1358..686c643f40 100644
--- a/target/linux/ramips/patches-3.18/0053-mmc-MIPS-ralink-add-sdhci-for-mt7620a-SoC.patch
+++ b/target/linux/ramips/patches-3.18/0053-mmc-MIPS-ralink-add-sdhci-for-mt7620a-SoC.patch
@@ -25,7 +25,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/mmc/host/Kconfig
+++ b/drivers/mmc/host/Kconfig
-@@ -773,3 +773,5 @@
+@@ -773,3 +773,5 @@ config MMC_SUNXI
help
This selects support for the SD/MMC Host Controller on
Allwinner sunxi SoCs.
diff --git a/target/linux/ramips/patches-3.18/0060-soc_type.patch b/target/linux/ramips/patches-3.18/0060-soc_type.patch
index 60d301405b..292a4ad456 100644
--- a/target/linux/ramips/patches-3.18/0060-soc_type.patch
+++ b/target/linux/ramips/patches-3.18/0060-soc_type.patch
@@ -110,8 +110,8 @@
if (xtal_rate == MHZ(40))
cpu_rate = MHZ(580);
else
-@@ -418,7 +416,7 @@ void __init ralink_clk_init(void)
- ralink_clk_add("10000c00.uartlite", periph_rate);
+@@ -420,7 +418,7 @@ void __init ralink_clk_init(void)
+ ralink_clk_add("10000e00.uart2", periph_rate);
ralink_clk_add("10180000.wmac", xtal_rate);
- if (IS_ENABLED(CONFIG_USB) && mt762x_soc != MT762X_SOC_MT7628AN) {
@@ -119,7 +119,7 @@
/*
* When the CPU goes into sleep mode, the BUS clock will be too low for
* USB to function properly
-@@ -506,11 +504,11 @@ void prom_soc_init(struct ralink_soc_inf
+@@ -508,11 +506,11 @@ void prom_soc_init(struct ralink_soc_inf
if (n0 == MT7620_CHIP_NAME0 && n1 == MT7620_CHIP_NAME1) {
if (bga) {
@@ -133,7 +133,7 @@
name = "MT7620N";
soc_info->compatible = "ralink,mt7620n-soc";
#ifdef CONFIG_PCI
-@@ -518,7 +516,7 @@ void prom_soc_init(struct ralink_soc_inf
+@@ -520,7 +518,7 @@ void prom_soc_init(struct ralink_soc_inf
#endif
}
} else if (n0 == MT7620_CHIP_NAME0 && n1 == MT7628_CHIP_NAME1) {
@@ -142,7 +142,7 @@
name = "MT7628AN";
soc_info->compatible = "ralink,mt7628an-soc";
} else {
-@@ -535,7 +533,7 @@ void prom_soc_init(struct ralink_soc_inf
+@@ -537,7 +535,7 @@ void prom_soc_init(struct ralink_soc_inf
dram_type = (cfg0 >> SYSCFG0_DRAM_TYPE_SHIFT) & SYSCFG0_DRAM_TYPE_MASK;
soc_info->mem_base = MT7620_DRAM_BASE;
@@ -151,7 +151,7 @@
mt7628_dram_init(soc_info);
else
mt7620_dram_init(soc_info);
-@@ -548,7 +546,7 @@ void prom_soc_init(struct ralink_soc_inf
+@@ -550,7 +548,7 @@ void prom_soc_init(struct ralink_soc_inf
pr_info("Digital PMU set to %s control\n",
(pmu1 & DIG_SW_SEL) ? ("sw") : ("hw"));
diff --git a/target/linux/ramips/patches-3.18/999-non-pci-mt7620.patch b/target/linux/ramips/patches-3.18/999-non-pci-mt7620.patch
index 815b1c7447..ce56ae2002 100644
--- a/target/linux/ramips/patches-3.18/999-non-pci-mt7620.patch
+++ b/target/linux/ramips/patches-3.18/999-non-pci-mt7620.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/ralink/mt7620.c
+++ b/arch/mips/ralink/mt7620.c
-@@ -511,9 +511,6 @@ void prom_soc_init(struct ralink_soc_inf
+@@ -513,9 +513,6 @@ void prom_soc_init(struct ralink_soc_inf
ralink_soc = MT762X_SOC_MT7620N;
name = "MT7620N";
soc_info->compatible = "ralink,mt7620n-soc";