summaryrefslogtreecommitdiffstats
path: root/target/linux/rb532/patches-2.6.24/120-cf.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-07-15 17:18:28 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-07-15 17:18:28 +0000
commitb0250695a9247aac244b770a0fb0d6deaad5467c (patch)
tree2bb27977d90b0912abb949aa056003cba3a00e09 /target/linux/rb532/patches-2.6.24/120-cf.patch
parent714a721010caa3941e7e178944c9e843c2108b59 (diff)
downloadmaster-31e0f0ae-b0250695a9247aac244b770a0fb0d6deaad5467c.tar.gz
master-31e0f0ae-b0250695a9247aac244b770a0fb0d6deaad5467c.tar.bz2
master-31e0f0ae-b0250695a9247aac244b770a0fb0d6deaad5467c.zip
Add basic 2.6.24 support for rb532, korina napi code has to be adapted to work
SVN-Revision: 11844
Diffstat (limited to 'target/linux/rb532/patches-2.6.24/120-cf.patch')
-rw-r--r--target/linux/rb532/patches-2.6.24/120-cf.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/rb532/patches-2.6.24/120-cf.patch b/target/linux/rb532/patches-2.6.24/120-cf.patch
new file mode 100644
index 0000000000..522195e451
--- /dev/null
+++ b/target/linux/rb532/patches-2.6.24/120-cf.patch
@@ -0,0 +1,31 @@
+Index: linux-2.6.23.17/drivers/block/Kconfig
+===================================================================
+--- linux-2.6.23.17.orig/drivers/block/Kconfig
++++ linux-2.6.23.17/drivers/block/Kconfig
+@@ -426,6 +426,14 @@ config SUNVDC
+ Support for virtual disk devices as a client under Sun
+ Logical Domains.
+
++config BLK_DEV_CF_MIPS
++ bool "CF slot of RB532 board"
++ depends on MIKROTIK_RB500
++ default y
++ help
++ The Routerboard 532 has a CF slot on it. Enable the special block
++ device driver for it.
++
+ source "drivers/s390/block/Kconfig"
+
+ config XILINX_SYSACE
+Index: linux-2.6.23.17/drivers/block/Makefile
+===================================================================
+--- linux-2.6.23.17.orig/drivers/block/Makefile
++++ linux-2.6.23.17/drivers/block/Makefile
+@@ -21,6 +21,7 @@ obj-$(CONFIG_BLK_DEV_DAC960) += DAC960.o
+ obj-$(CONFIG_XILINX_SYSACE) += xsysace.o
+ obj-$(CONFIG_CDROM_PKTCDVD) += pktcdvd.o
+ obj-$(CONFIG_SUNVDC) += sunvdc.o
++obj-$(CONFIG_BLK_DEV_CF_MIPS) += rb500/
+
+ obj-$(CONFIG_BLK_DEV_UMEM) += umem.o
+ obj-$(CONFIG_BLK_DEV_NBD) += nbd.o