summaryrefslogtreecommitdiffstats
path: root/target/linux/rdc-2.6/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
commit7a6a6464971c69fa1026aeaf8fad5c79250230e9 (patch)
treea68bcf07bd0d15b68d1b990877a55002585690b9 /target/linux/rdc-2.6/image/Makefile
parent927fb16abb41cfeeee4e97b4baed2d5ce036ca2e (diff)
downloadmaster-31e0f0ae-7a6a6464971c69fa1026aeaf8fad5c79250230e9.tar.gz
master-31e0f0ae-7a6a6464971c69fa1026aeaf8fad5c79250230e9.tar.bz2
master-31e0f0ae-7a6a6464971c69fa1026aeaf8fad5c79250230e9.zip
Add initial version of the new Image Builder It's still a bit rough in a few places, but it seems to work for Broadcom at least - other targets untested.
SVN-Revision: 6071
Diffstat (limited to 'target/linux/rdc-2.6/image/Makefile')
-rw-r--r--target/linux/rdc-2.6/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/rdc-2.6/image/Makefile b/target/linux/rdc-2.6/image/Makefile
index 13c8718430..078e754e10 100644
--- a/target/linux/rdc-2.6/image/Makefile
+++ b/target/linux/rdc-2.6/image/Makefile
@@ -11,11 +11,12 @@ define Build/Clean
endef
define Image/Prepare
+ $(CP) $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/bzImage
endef
define Image/Build
touch $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
- $(STAGING_DIR)/bin/airlink -b 0 -j $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+ $(STAGING_DIR)/bin/airlink -b 0 -j $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
endef
$(eval $(call BuildImage))