summaryrefslogtreecommitdiffstats
path: root/target/linux/x86/ep80579
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2010-04-01 12:05:27 +0000
committerImre Kaloz <kaloz@openwrt.org>2010-04-01 12:05:27 +0000
commitd3b9b93dd3df29460b21b1b4daa556f81f5780ba (patch)
treecc73f5514469c1e04792265df26b16380e00a843 /target/linux/x86/ep80579
parent6e383d7ef0894885429728affbf94c7d5a2bbe46 (diff)
downloadmaster-31e0f0ae-d3b9b93dd3df29460b21b1b4daa556f81f5780ba.tar.gz
master-31e0f0ae-d3b9b93dd3df29460b21b1b4daa556f81f5780ba.tar.bz2
master-31e0f0ae-d3b9b93dd3df29460b21b1b4daa556f81f5780ba.zip
add a subtarget and drivers for the Intel Tolapai SoC
SVN-Revision: 20648
Diffstat (limited to 'target/linux/x86/ep80579')
-rw-r--r--target/linux/x86/ep80579/config-default12
-rw-r--r--target/linux/x86/ep80579/target.mk9
2 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/x86/ep80579/config-default b/target/linux/x86/ep80579/config-default
new file mode 100644
index 0000000000..2a89b4fe6f
--- /dev/null
+++ b/target/linux/x86/ep80579/config-default
@@ -0,0 +1,12 @@
+CONFIG_ATA=y
+CONFIG_BLK_DEV_SD=y
+# CONFIG_MTD_BLOCK2MTD is not set
+CONFIG_HIGHMEM4G=y
+# CONFIG_HIGHPTE is not set
+# CONFIG_MTD is not set
+# CONFIG_NOHIGHMEM is not set
+CONFIG_SATA_AHCI=y
+# CONFIG_SQUASHFS is not set
+CONFIG_ITCO_WDT=y
+# CONFIG_ITCO_VENDOR_SUPPORT is not set
+CONFIG_LOG_BUF_SHIFT=17
diff --git a/target/linux/x86/ep80579/target.mk b/target/linux/x86/ep80579/target.mk
new file mode 100644
index 0000000000..00fe1abc3d
--- /dev/null
+++ b/target/linux/x86/ep80579/target.mk
@@ -0,0 +1,9 @@
+BOARDNAME:=Intel EP80579
+DEFAULT_PACKAGES += kmod-ep80579-can kmod-ep80579-eth kmod-ep80579-misc \
+ kmod-usb-core kmod-usb2 kmod-usb-hid kmod-usb-uhci
+
+define Target/Description
+ Build firmware images for Intel EP80579 based boards
+ (e.g : ADI Engineering Ocracoke Island)
+endef
+