summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-09-12 06:52:42 +0000
committerJohn Crispin <john@openwrt.org>2014-09-12 06:52:42 +0000
commit09f38a3f766ee23016fa1c456ec75df5c37364e7 (patch)
tree23f33cb1edbffd7073ee29e29f1461e498476f9d /target/linux
parent2e9deed90a9fcb5ec13976b64e7969f2c9aa5a25 (diff)
downloadmaster-31e0f0ae-09f38a3f766ee23016fa1c456ec75df5c37364e7.tar.gz
master-31e0f0ae-09f38a3f766ee23016fa1c456ec75df5c37364e7.tar.bz2
master-31e0f0ae-09f38a3f766ee23016fa1c456ec75df5c37364e7.zip
atheros: remove odd ATHEROS_AR2315 config symbol dependencies
Remove options which already selected by ATHEROS_AR231X on which ATHEROS_AR2315 depends. Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com> SVN-Revision: 42497
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/atheros/patches-3.14/100-board.patch9
-rw-r--r--target/linux/atheros/patches-3.14/105-ar2315_pci.patch6
2 files changed, 4 insertions, 11 deletions
diff --git a/target/linux/atheros/patches-3.14/100-board.patch b/target/linux/atheros/patches-3.14/100-board.patch
index 4840813669..7b1adbd711 100644
--- a/target/linux/atheros/patches-3.14/100-board.patch
+++ b/target/linux/atheros/patches-3.14/100-board.patch
@@ -49,7 +49,7 @@
+load-$(CONFIG_ATHEROS_AR231X) += 0xffffffff80041000
--- /dev/null
+++ b/arch/mips/ar231x/Kconfig
-@@ -0,0 +1,16 @@
+@@ -0,0 +1,9 @@
+config ATHEROS_AR5312
+ bool "Atheros 5312/2312+ support"
+ depends on ATHEROS_AR231X
@@ -58,13 +58,6 @@
+config ATHEROS_AR2315
+ bool "Atheros 2315+ support"
+ depends on ATHEROS_AR231X
-+ select DMA_NONCOHERENT
-+ select CEVT_R4K
-+ select CSRC_R4K
-+ select IRQ_CPU
-+ select SYS_HAS_CPU_MIPS32_R1
-+ select SYS_SUPPORTS_32BIT_KERNEL
-+ select SYS_SUPPORTS_BIG_ENDIAN
+ default y
--- /dev/null
+++ b/arch/mips/ar231x/Makefile
diff --git a/target/linux/atheros/patches-3.14/105-ar2315_pci.patch b/target/linux/atheros/patches-3.14/105-ar2315_pci.patch
index 53222a1af2..14862c9e5e 100644
--- a/target/linux/atheros/patches-3.14/105-ar2315_pci.patch
+++ b/target/linux/atheros/patches-3.14/105-ar2315_pci.patch
@@ -243,9 +243,9 @@
+arch_initcall(ar2315_pci_init);
--- a/arch/mips/ar231x/Kconfig
+++ b/arch/mips/ar231x/Kconfig
-@@ -14,3 +14,10 @@ config ATHEROS_AR2315
- select SYS_SUPPORTS_32BIT_KERNEL
- select SYS_SUPPORTS_BIG_ENDIAN
+@@ -7,3 +7,10 @@ config ATHEROS_AR2315
+ bool "Atheros 2315+ support"
+ depends on ATHEROS_AR231X
default y
+
+config ATHEROS_AR2315_PCI