summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-12-11 17:56:15 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-12-11 17:56:15 +0000
commita8b83afe372c03575f4de568df81d7a7c2d742d0 (patch)
tree288c0c02aaf5e57c4e071bb9d89bbc3658229dbf /target
parent618bb267371e45108bafef9c2414258be6621540 (diff)
downloadmaster-31e0f0ae-a8b83afe372c03575f4de568df81d7a7c2d742d0.tar.gz
master-31e0f0ae-a8b83afe372c03575f4de568df81d7a7c2d742d0.tar.bz2
master-31e0f0ae-a8b83afe372c03575f4de568df81d7a7c2d742d0.zip
Add Wi-Fi profiles (for what it matters with this arch)
SVN-Revision: 5763
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm63xx-2.6/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/brcm63xx-2.6/Makefile b/target/linux/brcm63xx-2.6/Makefile
index b8da70e133..d7b71c803e 100644
--- a/target/linux/brcm63xx-2.6/Makefile
+++ b/target/linux/brcm63xx-2.6/Makefile
@@ -21,4 +21,17 @@ LINUX_RELEASE:=1
LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
include $(INCLUDE_DIR)/kernel-build.mk
+
+define Profile/Broadcom
+ NAME:=Broadcom WiFi (default)
+ PACKAGES:=kmod-net-bcm43xx
+endef
+$(eval $(call Profile,Broadcom))
+
+define Profile/Atheros
+ NAME:=Atheros WiFi
+ PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
$(eval $(call BuildKernel))