summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-02-18 10:57:43 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-02-18 10:57:43 +0000
commite97d74eaab4e0fe45f4e41b528fff3ca44186208 (patch)
tree0bd97189d629354b51b1ac32a7d74a6f5d564004 /target
parent5bd47dc8bd8b44933c0888c304cd66851551a56f (diff)
downloadmaster-31e0f0ae-e97d74eaab4e0fe45f4e41b528fff3ca44186208.tar.gz
master-31e0f0ae-e97d74eaab4e0fe45f4e41b528fff3ca44186208.tar.bz2
master-31e0f0ae-e97d74eaab4e0fe45f4e41b528fff3ca44186208.zip
upgrade apex to 1.5.13, fixup EABI support
SVN-Revision: 10484
Diffstat (limited to 'target')
-rw-r--r--target/linux/ixp4xx/image/apex/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/ixp4xx/image/apex/Makefile b/target/linux/ixp4xx/image/apex/Makefile
index 759a4ef75b..789d4f2131 100644
--- a/target/linux/ixp4xx/image/apex/Makefile
+++ b/target/linux/ixp4xx/image/apex/Makefile
@@ -9,14 +9,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=apex
-PKG_VERSION:=1.5.8
+PKG_VERSION:=1.5.13
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.buici.com/pub/apex/ \
ftp://metalab.unc.edu/pub/Linux/system/boot/apex/
-PKG_MD5SUM:=bb96cc8d50b4f00ee653f0800643ea8a
+PKG_MD5SUM:=5feb7a05431e5e8a4aa36fb23347de8e
include $(INCLUDE_DIR)/package.mk
@@ -24,6 +24,7 @@ define Build/Configure
$(MAKE) -C $(PKG_BUILD_DIR) \
ARCH=arm \
slugos-nslu2-armeb_config
+ $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(PKG_BUILD_DIR)/.config
endef
define Build/Compile