summaryrefslogtreecommitdiffstats
path: root/toolchain/binutils/patches/2.17/501-avr32-fix-pool-alignment.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-12-28 18:26:50 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-12-28 18:26:50 +0000
commit8700cac7110aeaf95fa26482323e14c35b7f07fb (patch)
tree1168d094fac88a9d0bb88805e3be11aeb4e22875 /toolchain/binutils/patches/2.17/501-avr32-fix-pool-alignment.patch
parent3e3b877d14c725691920b608b6dda5d78f8ff50d (diff)
downloadmaster-31e0f0ae-8700cac7110aeaf95fa26482323e14c35b7f07fb.tar.gz
master-31e0f0ae-8700cac7110aeaf95fa26482323e14c35b7f07fb.tar.bz2
master-31e0f0ae-8700cac7110aeaf95fa26482323e14c35b7f07fb.zip
update AVR32 binutils patches
SVN-Revision: 10006
Diffstat (limited to 'toolchain/binutils/patches/2.17/501-avr32-fix-pool-alignment.patch')
-rw-r--r--toolchain/binutils/patches/2.17/501-avr32-fix-pool-alignment.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/toolchain/binutils/patches/2.17/501-avr32-fix-pool-alignment.patch b/toolchain/binutils/patches/2.17/501-avr32-fix-pool-alignment.patch
new file mode 100644
index 0000000000..bd519a1e69
--- /dev/null
+++ b/toolchain/binutils/patches/2.17/501-avr32-fix-pool-alignment.patch
@@ -0,0 +1,26 @@
+Index: a/gas/config/tc-avr32.c
+===================================================================
+--- a/gas/config/tc-avr32.c (revision 31496)
++++ b/gas/config/tc-avr32.c (revision 32014)
+@@ -3092,6 +3092,8 @@
+
+ /* Make sure the constant pool is properly aligned */
+ frag_align_code(2, 0);
++ if (bfd_get_section_alignment(stdoutput, pool->section) < 2)
++ bfd_set_section_alignment(stdoutput, pool->section, 2);
+
+ /* Assume none of the entries are discarded, and that we need the
+ maximum amount of alignment. But we're not going to allocate
+Index: a/bfd/configure.in
+===================================================================
+--- a/bfd/configure.in (revision 31496)
++++ b/bfd/configure.in (revision 32014)
+@@ -8,7 +8,7 @@
+ AC_CANONICAL_TARGET
+ AC_ISC_POSIX
+
+-AM_INIT_AUTOMAKE(bfd, 2.17.atmel.1.2.0)
++AM_INIT_AUTOMAKE(bfd, 2.17.atmel.1.2.1)
+
+ dnl These must be called before AM_PROG_LIBTOOL, because it may want
+ dnl to call AC_CHECK_PROG.