summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-12 03:42:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-12 03:42:05 +0000
commit646342f30f409ac8030b634f2715ab9acac07858 (patch)
treeb60a342134a393ec5a6c8b376ad26335cbd0f4de /toolchain/gcc
parentb8712cb816fc0d0d7b6c15be6e06d9dc3d3164be (diff)
downloadmaster-31e0f0ae-646342f30f409ac8030b634f2715ab9acac07858.tar.gz
master-31e0f0ae-646342f30f409ac8030b634f2715ab9acac07858.tar.bz2
master-31e0f0ae-646342f30f409ac8030b634f2715ab9acac07858.zip
fix gcc compile
SVN-Revision: 5511
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index af06e8a4c1..a738345d2e 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -64,10 +64,10 @@ define Stage1/Configure
);
endef
define Stage1/Compile
- $(MAKE) -C $(BUILD_DIR1) all-gcc SHELL="$(BASH)"
+ export SHELL="$(BASH)"; $(MAKE) -C $(BUILD_DIR1) all-gcc
endef
define Stage1/Install
- $(MAKE) -C $(BUILD_DIR1) install-gcc SHELL="$(BASH)"
+ export SHELL="$(BASH)"; $(MAKE) -C $(BUILD_DIR1) install-gcc
endef
define Stage2/Configure
@@ -93,10 +93,10 @@ define Stage2/Configure
);
endef
define Stage2/Compile
- $(MAKE) -C $(BUILD_DIR2) all SHELL="$(BASH)"
+ export SHELL="$(BASH)"; $(MAKE) -C $(BUILD_DIR2) all
endef
define Stage2/Install
- $(MAKE) -C $(BUILD_DIR2) install SHELL="$(BASH)"
+ export SHELL="$(BASH)"; $(MAKE) -C $(BUILD_DIR2) install
echo $(PKG_VERSION) > $(STAGING_DIR)/gcc_version
# Set up the symlinks to enable lying about target name.
set -e; \