summaryrefslogtreecommitdiffstats
path: root/toolchain/gdb/patches/100-ppc_compile_fix.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-06-11 13:25:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-06-11 13:25:00 +0000
commitbe20fe9771176f3854b6db965185bfa0c0527c79 (patch)
tree32e9db39c57f7e56fb35beb57b44e59b09727875 /toolchain/gdb/patches/100-ppc_compile_fix.patch
parent70106f153d3c868110fce66f2e968e0fd8c58e41 (diff)
downloadmaster-31e0f0ae-be20fe9771176f3854b6db965185bfa0c0527c79.tar.gz
master-31e0f0ae-be20fe9771176f3854b6db965185bfa0c0527c79.tar.bz2
master-31e0f0ae-be20fe9771176f3854b6db965185bfa0c0527c79.zip
toolchain/gdb: fix compile for powerpc targets, refresh patch
SVN-Revision: 27155
Diffstat (limited to 'toolchain/gdb/patches/100-ppc_compile_fix.patch')
-rw-r--r--toolchain/gdb/patches/100-ppc_compile_fix.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/toolchain/gdb/patches/100-ppc_compile_fix.patch b/toolchain/gdb/patches/100-ppc_compile_fix.patch
new file mode 100644
index 0000000000..4c5cb4efd9
--- /dev/null
+++ b/toolchain/gdb/patches/100-ppc_compile_fix.patch
@@ -0,0 +1,11 @@
+--- a/sim/ppc/Makefile.in
++++ b/sim/ppc/Makefile.in
+@@ -551,7 +551,7 @@ PACKAGE_SRC = @sim_pk_src@
+ PACKAGE_OBJ = @sim_pk_obj@
+
+
+-psim: $(TARGETLIB) main.o $(LIBIBERTY_LIB) $(BFD_LIB) $(LIBS) $(LIBINTL_DEP)
++psim: $(TARGETLIB) main.o $(LIBIBERTY_LIB) $(BFD_LIB) $(LIBINTL_DEP)
+ $(CC) $(CFLAGS) $(SIM_CFLAGS) $(LDFLAGS) -o psim$(EXEEXT) main.o $(TARGETLIB) $(BFD_LIB) $(LIBINTL) $(LIBIBERTY_LIB) $(LIBS)
+
+ run: psim