summaryrefslogtreecommitdiffstats
path: root/toolchain/llvm/patches/110-darwin_version_detect.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-10 19:25:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-10 19:25:48 +0000
commit215ccb66e6abdaed0a41582d6b8c40ffa340eea7 (patch)
treee8ecd7ecc708bda6515831abaffbcb8d9ee65d5f /toolchain/llvm/patches/110-darwin_version_detect.patch
parentb49cdabd4ae2c0239dc12eda5e1b7a21b9c2e5dc (diff)
downloadmaster-31e0f0ae-215ccb66e6abdaed0a41582d6b8c40ffa340eea7.tar.gz
master-31e0f0ae-215ccb66e6abdaed0a41582d6b8c40ffa340eea7.tar.bz2
master-31e0f0ae-215ccb66e6abdaed0a41582d6b8c40ffa340eea7.zip
gcc: add llvm-gcc and llvm from trunk (does not successfully compile a target yet, but gets close)
SVN-Revision: 18019
Diffstat (limited to 'toolchain/llvm/patches/110-darwin_version_detect.patch')
-rw-r--r--toolchain/llvm/patches/110-darwin_version_detect.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/toolchain/llvm/patches/110-darwin_version_detect.patch b/toolchain/llvm/patches/110-darwin_version_detect.patch
new file mode 100644
index 0000000000..7fd62f93ee
--- /dev/null
+++ b/toolchain/llvm/patches/110-darwin_version_detect.patch
@@ -0,0 +1,16 @@
+--- a/Makefile.rules
++++ b/Makefile.rules
+@@ -506,11 +506,13 @@ endif
+ #--------------------------------------------------------------------
+
+ ifeq ($(HOST_OS),Darwin)
++ ifndef DARWIN_VERSION
+ DARWIN_VERSION := `sw_vers -productVersion`
+ # Strip a number like 10.4.7 to 10.4
+ DARWIN_VERSION := $(shell echo $(DARWIN_VERSION)| sed -E 's/(10.[0-9]).*/\1/')
+ # Get "4" out of 10.4 for later pieces in the makefile.
+ DARWIN_MAJVERS := $(shell echo $(DARWIN_VERSION)| sed -E 's/10.([0-9]).*/\1/')
++ endif
+
+ SharedLinkOptions=-Wl,-flat_namespace -Wl,-undefined -Wl,suppress \
+ -dynamiclib