summaryrefslogtreecommitdiffstats
path: root/toolchain/llvm/patches
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-15 12:03:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-15 12:03:01 +0000
commit808c4602508f6b007ff3f6b3fd2a66afb67deef3 (patch)
tree1e3a4113cf00b0279281ff16a3863a6d02d21939 /toolchain/llvm/patches
parent4b1165d5c7bafe91f8ac46ca41dd7bbd57a875e7 (diff)
downloadmaster-31e0f0ae-808c4602508f6b007ff3f6b3fd2a66afb67deef3.tar.gz
master-31e0f0ae-808c4602508f6b007ff3f6b3fd2a66afb67deef3.tar.bz2
master-31e0f0ae-808c4602508f6b007ff3f6b3fd2a66afb67deef3.zip
toolchain: remove leftovers from old llvm-gcc experiments
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 44783
Diffstat (limited to 'toolchain/llvm/patches')
-rw-r--r--toolchain/llvm/patches/100-darwin_arch_auto.patch19
-rw-r--r--toolchain/llvm/patches/110-darwin_version_detect.patch16
2 files changed, 0 insertions, 35 deletions
diff --git a/toolchain/llvm/patches/100-darwin_arch_auto.patch b/toolchain/llvm/patches/100-darwin_arch_auto.patch
deleted file mode 100644
index a48e131219..0000000000
--- a/toolchain/llvm/patches/100-darwin_arch_auto.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/Makefile.rules
-+++ b/Makefile.rules
-@@ -618,16 +618,6 @@ ifdef UNIVERSAL
-
- # Building universal cannot compute dependencies automatically.
- DISABLE_AUTO_DEPENDENCIES=1
--else
-- ifeq ($(TARGET_OS),Darwin)
-- ifeq ($(ARCH),x86_64)
-- TargetCommonOpts = -m64
-- else
-- ifeq ($(ARCH),x86)
-- TargetCommonOpts = -m32
-- endif
-- endif
-- endif
- endif
-
- ifeq ($(HOST_OS),SunOS)
diff --git a/toolchain/llvm/patches/110-darwin_version_detect.patch b/toolchain/llvm/patches/110-darwin_version_detect.patch
deleted file mode 100644
index 7fd62f93ee..0000000000
--- a/toolchain/llvm/patches/110-darwin_version_detect.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/Makefile.rules
-+++ b/Makefile.rules
-@@ -506,11 +506,13 @@ endif
- #--------------------------------------------------------------------
-
- ifeq ($(HOST_OS),Darwin)
-+ ifndef DARWIN_VERSION
- DARWIN_VERSION := `sw_vers -productVersion`
- # Strip a number like 10.4.7 to 10.4
- DARWIN_VERSION := $(shell echo $(DARWIN_VERSION)| sed -E 's/(10.[0-9]).*/\1/')
- # Get "4" out of 10.4 for later pieces in the makefile.
- DARWIN_MAJVERS := $(shell echo $(DARWIN_VERSION)| sed -E 's/10.([0-9]).*/\1/')
-+ endif
-
- SharedLinkOptions=-Wl,-flat_namespace -Wl,-undefined -Wl,suppress \
- -dynamiclib