summaryrefslogtreecommitdiffstats
path: root/toolchain/musl/headers
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-11-23 20:02:29 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-11-23 20:02:29 +0000
commit6b63716262b89bec53402817876116898936d5f4 (patch)
tree1d792a9083d34dc6e40620b3c5802e9168a461e0 /toolchain/musl/headers
parent14ed3f0f22f34b337bb58b2a5fd09e887df3331f (diff)
downloadmaster-31e0f0ae-6b63716262b89bec53402817876116898936d5f4.tar.gz
master-31e0f0ae-6b63716262b89bec53402817876116898936d5f4.tar.bz2
master-31e0f0ae-6b63716262b89bec53402817876116898936d5f4.zip
add preliminary support for musl
Musl is an alternative C-library, see http://www.musl-libc.org for more infos. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 34314
Diffstat (limited to 'toolchain/musl/headers')
-rw-r--r--toolchain/musl/headers/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/toolchain/musl/headers/Makefile b/toolchain/musl/headers/Makefile
new file mode 100644
index 0000000000..21e6b3bd15
--- /dev/null
+++ b/toolchain/musl/headers/Makefile
@@ -0,0 +1,16 @@
+PATH_PREFIX:=..
+
+include ../common.mk
+
+HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.headers_built
+HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.uclibc_headers_installed
+
+define Host/Compile
+
+endef
+
+define Host/Install
+endef
+
+$(eval $(call HostBuild))
+