summaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/patches-0.9.28/150-portability.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-23 17:56:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-23 17:56:28 +0000
commit03205ec7407b379602abd8bb0c41c62fe28151f4 (patch)
tree76657f61fec7fb956d0f09834ab6947f3b8aa4a6 /toolchain/uClibc/patches-0.9.28/150-portability.patch
parentfc9181c4e25fa55aa13ff2b2960fe45d68080100 (diff)
downloadmaster-31e0f0ae-03205ec7407b379602abd8bb0c41c62fe28151f4.tar.gz
master-31e0f0ae-03205ec7407b379602abd8bb0c41c62fe28151f4.tar.bz2
master-31e0f0ae-03205ec7407b379602abd8bb0c41c62fe28151f4.zip
clean up uclibc patch/config version handling a bit
SVN-Revision: 14994
Diffstat (limited to 'toolchain/uClibc/patches-0.9.28/150-portability.patch')
-rw-r--r--toolchain/uClibc/patches-0.9.28/150-portability.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/toolchain/uClibc/patches-0.9.28/150-portability.patch b/toolchain/uClibc/patches-0.9.28/150-portability.patch
new file mode 100644
index 0000000000..c3a85107c8
--- /dev/null
+++ b/toolchain/uClibc/patches-0.9.28/150-portability.patch
@@ -0,0 +1,29 @@
+Fix portability of build infrastructure
+* cp -d -> cp -P
+* tar --exclude is a GNU tar feature
+
+--- uClibc-0.9.28/Makefile.orig Sun Jun 11 19:08:56 2006
++++ uClibc-0.9.28/Makefile Sun Jun 11 19:12:05 2006
+@@ -158,12 +158,7 @@ install_dev:
+ $(INSTALL) -d $(PREFIX)$(DEVEL_PREFIX)lib
+ $(INSTALL) -d $(PREFIX)$(DEVEL_PREFIX)include
+ -$(INSTALL) -m 644 lib/*.[ao] $(PREFIX)$(DEVEL_PREFIX)lib/
+- if [ "$(KERNEL_SOURCE)" = "$(DEVEL_PREFIX)" ] ; then \
+- extra_exclude="--exclude include/linux --exclude include/asm'*'" ; \
+- else \
+- extra_exclude="" ; \
+- fi ; \
+- tar -chf - include --exclude .svn --exclude CVS $$extra_exclude \
++ tar -chf - include \
+ | tar -xf - -C $(PREFIX)$(DEVEL_PREFIX)
+ ifneq ($(strip $(UCLIBC_HAS_FLOATS)),y)
+ # Remove floating point related headers since float support is disabled.
+@@ -253,7 +248,7 @@ ifeq ($(strip $(HAVE_SHARED)),y)
+ $(INSTALL) -d $(PREFIX)$(RUNTIME_PREFIX)lib
+ $(INSTALL) -m 644 lib/lib*-$(MAJOR_VERSION).$(MINOR_VERSION).$(SUBLEVEL).so \
+ $(PREFIX)$(RUNTIME_PREFIX)lib
+- cp -dRf lib/*.so.* $(PREFIX)$(RUNTIME_PREFIX)lib
++ cp -pRf lib/*.so.* $(PREFIX)$(RUNTIME_PREFIX)lib
+ @if [ -x lib/ld-uClibc-$(MAJOR_VERSION).$(MINOR_VERSION).$(SUBLEVEL).so ] ; then \
+ set -e; \
+ $(SHELL_SET_X); \