summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-28 02:53:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-28 02:53:54 +0000
commit02a7e555debc912845757f1609a159ee3c2af4b4 (patch)
tree985eb37f90178aebdfc24dd7a6654c824e9b2ab7 /tools
parent81529c47ec26f951a849c54922db22f38848ed95 (diff)
downloadmaster-31e0f0ae-02a7e555debc912845757f1609a159ee3c2af4b4.tar.gz
master-31e0f0ae-02a7e555debc912845757f1609a159ee3c2af4b4.tar.bz2
master-31e0f0ae-02a7e555debc912845757f1609a159ee3c2af4b4.zip
don't force the install->compile, compile->prepare dependencies in subdir.mk
SVN-Revision: 8202
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 0d6b515977..49b30be44b 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -23,6 +23,9 @@ $(STAGING_DIR)/include-host/.done:
# prerequisites for the individual targets
$(curdir)/ := .config
-$(curdir)//prepare := $(STAGING_DIR)/include-host/.done
+$(curdir)//prepare = $(STAGING_DIR)/include-host/.done
+$(curdir)//compile = $(1)/prepare
+$(curdir)//install = $(1)/compile
+
$(eval $(call stampfile,$(curdir),tools))
$(eval $(call subdir,$(curdir)))