summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-18 19:00:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-18 19:00:05 +0000
commit6a2879bfe766bdc09d26980d5dcdedfeee2055a5 (patch)
treecbcff442f83686af3d623f89d23343330d1e2f35 /tools
parent5884dd62545fad411d59aa12b6933c3bf44a0d7e (diff)
downloadmaster-31e0f0ae-6a2879bfe766bdc09d26980d5dcdedfeee2055a5.tar.gz
master-31e0f0ae-6a2879bfe766bdc09d26980d5dcdedfeee2055a5.tar.bz2
master-31e0f0ae-6a2879bfe766bdc09d26980d5dcdedfeee2055a5.zip
improve parallel building
SVN-Revision: 5208
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index c8fad23236..eeadde2ed6 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -16,7 +16,9 @@ TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
all: install
download: $(TARGETS_DOWNLOAD)
-install: $(TARGETS_INSTALL)
+install:
+ $(MAKE) install-targets
+install-targets: $(TARGETS_INSTALL)
clean: $(TARGETS_CLEAN)
squashfs-compile: lzma-install
@@ -58,3 +60,8 @@ $(TOOL_BUILD_DIR):
@$(MAKE) -C $(patsubst %-clean,%,$@) clean
@rm -f $(TOOL_STAMP_DIR)/.tool_$(patsubst %-clean,%,$@)-*
+ifeq ($(MAKECMDGOALS),install-targets)
+MAKEFLAGS:=$(MAKEFLAGS) -j$(CONFIG_JLEVEL)
+else
+.NOTPARALLEL:
+endif