summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/wget2nand/Makefile37
-rwxr-xr-xtarget/linux/adm5120-2.6/base-files/default/sbin/wget2nand (renamed from package/wget2nand/src/wget2nand)1
-rw-r--r--target/linux/adm5120-2.6/profiles/RB1xx.mk2
3 files changed, 2 insertions, 38 deletions
diff --git a/package/wget2nand/Makefile b/package/wget2nand/Makefile
deleted file mode 100644
index e029a502e9..0000000000
--- a/package/wget2nand/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id: $
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=wget2nand
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/wget2nand
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=RouterOS to OpenWrt install script
- DEPENDS:=@LINUX_2_6_ADM5120
- DESCRIPTION:=\
- A tool to switch from RouterBoard RouterOS to OpenWrt
- URL:=https://dev.openwrt.org/browser/trunk/package/wget2nand/src/wget2nand
- VERSION:=1
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-endef
-
-define Package/wget2nand/install
- $(INSTALL_DIR) $(1)/sbin
- $(INSTALL_BIN) ./src/$(PKG_NAME) $(1)/sbin/
-endef
-
-$(eval $(call BuildPackage,wget2nand))
diff --git a/package/wget2nand/src/wget2nand b/target/linux/adm5120-2.6/base-files/default/sbin/wget2nand
index 9588396fdf..1f7548aa06 100755
--- a/package/wget2nand/src/wget2nand
+++ b/target/linux/adm5120-2.6/base-files/default/sbin/wget2nand
@@ -58,6 +58,7 @@ echo "Patching the kernel command line"
chmod +x /tmp/wget2nand-boot/kernel
# make sure everything is written before we unmount the partitions
+echo "chmod ugo+x /" > /tmp/wget2nand/etc/uci-defaults/set_root_permission
sync
ls /tmp/wget2nand-boot/
ls /tmp/wget2nand/
diff --git a/target/linux/adm5120-2.6/profiles/RB1xx.mk b/target/linux/adm5120-2.6/profiles/RB1xx.mk
index d832523a26..8bede7a79a 100644
--- a/target/linux/adm5120-2.6/profiles/RB1xx.mk
+++ b/target/linux/adm5120-2.6/profiles/RB1xx.mk
@@ -7,7 +7,7 @@
define Profile/RouterBoard
NAME:=RouterBoard RB1xx
- PACKAGES:=kmod-madwifi patch-cmdline wget2nand
+ PACKAGES:=kmod-madwifi patch-cmdline
endef
define Profile/RouterBoard/Description