summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/brcm47xx/image/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 9f06e0f541..a5c7240c97 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -164,6 +164,26 @@ define Image/Build/generic/squashfs
endef
#################################################
+# Subtarget mips74k
+#################################################
+
+# $(1): filesystem type.
+define Image/Build/mips74k/jffs2-64k
+ $(call Image/Build/mips74k/devices-with-64k-blocks,$(1))
+endef
+
+# $(1): filesystem type.
+define Image/Build/mips74k/jffs2-128k
+ $(call Image/Build/mips74k/devices-with-128k-blocks,$(1))
+endef
+
+# $(1): filesystem type.
+define Image/Build/mips74k/squashfs
+ $(call Image/Build/mips74k/devices-with-64k-blocks,$(1))
+ $(call Image/Build/mips74k/devices-with-128k-blocks,$(1))
+endef
+
+#################################################
# Shared BuildImage defines
#################################################