summaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-envtools/patches
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-envtools/patches')
-rw-r--r--package/boot/uboot-envtools/patches/001-compile.patch13
-rw-r--r--package/boot/uboot-envtools/patches/001-honor_opt_flags.patch12
2 files changed, 13 insertions, 12 deletions
diff --git a/package/boot/uboot-envtools/patches/001-compile.patch b/package/boot/uboot-envtools/patches/001-compile.patch
new file mode 100644
index 0000000000..5e038ce729
--- /dev/null
+++ b/package/boot/uboot-envtools/patches/001-compile.patch
@@ -0,0 +1,13 @@
+--- a/tools/env/Makefile
++++ b/tools/env/Makefile
+@@ -10,6 +10,10 @@
+ # with "CC" here for the maximum code reuse of scripts/Makefile.host.
+ HOSTCC = $(CC)
+
++ifneq ($(TARGET_CFLAGS),)
++HOSTCFLAGS = $(TARGET_CFLAGS)
++endif
++
+ # Compile for a hosted environment on the target
+ HOST_EXTRACFLAGS = $(patsubst -I%,-idirafter%, $(UBOOTINCLUDE)) \
+ -idirafter $(srctree)/tools/env \
diff --git a/package/boot/uboot-envtools/patches/001-honor_opt_flags.patch b/package/boot/uboot-envtools/patches/001-honor_opt_flags.patch
deleted file mode 100644
index 16c3920bd6..0000000000
--- a/package/boot/uboot-envtools/patches/001-honor_opt_flags.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/config.mk
-+++ b/config.mk
-@@ -62,7 +62,8 @@ PLATFORM_LDFLAGS =
-
- #########################################################################
-
--HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer \
-+HOSTOPTFLAGS = -O2 -fomit-frame-pointer
-+HOSTCFLAGS = -Wall -Wstrict-prototypes $(HOSTOPTFLAGS) \
- $(HOSTCPPFLAGS)
- HOSTSTRIP = strip
-