summaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/patches/400-ath_move_debug_code.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/mac80211/patches/400-ath_move_debug_code.patch')
-rw-r--r--package/kernel/mac80211/patches/400-ath_move_debug_code.patch6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/kernel/mac80211/patches/400-ath_move_debug_code.patch b/package/kernel/mac80211/patches/400-ath_move_debug_code.patch
index 636df1fe8a..ccd4a3e501 100644
--- a/package/kernel/mac80211/patches/400-ath_move_debug_code.patch
+++ b/package/kernel/mac80211/patches/400-ath_move_debug_code.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/wireless/ath/Makefile
+++ b/drivers/net/wireless/ath/Makefile
-@@ -13,8 +13,8 @@ ath-objs := main.o \
+@@ -13,10 +13,10 @@ ath-objs := main.o \
regd.o \
hw.o \
key.o \
@@ -9,10 +9,12 @@
dfs_pri_detector.o
-ath-$(CPTCFG_ATH_DEBUG) += debug.o
+ ath-$(CPTCFG_ATH_TRACEPOINTS) += trace.o
+
ccflags-y += -D__CHECK_ENDIAN__
--- a/drivers/net/wireless/ath/ath.h
+++ b/drivers/net/wireless/ath/ath.h
-@@ -299,13 +299,6 @@ void _ath_dbg(struct ath_common *common,
+@@ -300,13 +300,6 @@ void _ath_dbg(struct ath_common *common,
#endif /* CPTCFG_ATH_DEBUG */
/** Returns string describing opmode, or NULL if unknown mode. */