summaryrefslogtreecommitdiffstats
path: root/package/network/config
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/config')
-rw-r--r--package/network/config/firewall/Makefile2
-rw-r--r--package/network/config/qos-scripts/Makefile3
-rw-r--r--package/network/config/soloscli/Makefile3
-rw-r--r--package/network/config/swconfig/Makefile3
4 files changed, 11 insertions, 0 deletions
diff --git a/package/network/config/firewall/Makefile b/package/network/config/firewall/Makefile
index b1d50a19f1..e224c92803 100644
--- a/package/network/config/firewall/Makefile
+++ b/package/network/config/firewall/Makefile
@@ -19,6 +19,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
PKG_LICENSE:=ISC
+PKG_LICENSE:=ISC
+PKG_LICENSE_FILES:=
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
diff --git a/package/network/config/qos-scripts/Makefile b/package/network/config/qos-scripts/Makefile
index a6690a161a..257b2f7572 100644
--- a/package/network/config/qos-scripts/Makefile
+++ b/package/network/config/qos-scripts/Makefile
@@ -13,6 +13,9 @@ PKG_RELEASE:=6
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=
+
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/config/soloscli/Makefile b/package/network/config/soloscli/Makefile
index 12bc15eaca..ba55a1e4a7 100644
--- a/package/network/config/soloscli/Makefile
+++ b/package/network/config/soloscli/Makefile
@@ -16,6 +16,9 @@ PKG_SOURCE_URL:=@SF/openadsl
PKG_MD5SUM:=c398866de3c059b14eb953c89d698124
PKG_LICENSE:=GPL-2.0
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=soloscli/COPYING.GPL
+
PKG_BUILD_DIR:=$(BUILD_DIR)/solos-pci-$(PKG_VERSION)
PKG_BUILD_PARALLEL:=1
diff --git a/package/network/config/swconfig/Makefile b/package/network/config/swconfig/Makefile
index 7d0f30e7bb..fb951da3ac 100644
--- a/package/network/config/swconfig/Makefile
+++ b/package/network/config/swconfig/Makefile
@@ -13,6 +13,9 @@ PKG_RELEASE:=10
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
PKG_LICENSE:=GPL-2.0
+PKG_LICENSE:=GPL-2.0 LGPL-2.1
+PKG_LICENSE_FILES:=
+
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/kernel.mk