summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netsupport.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 77bd67a7c3..8a923ed66e 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -1001,3 +1001,25 @@ define KernelPackage/rxrpc/description
endef
$(eval $(call KernelPackage,rxrpc))
+
+define KernelPackage/mpls
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=MPLS support
+ KCONFIG:= \
+ CONFIG_MPLS=y \
+ CONFIG_LWTUNNEL=y \
+ CONFIG_NET_MPLS_GSO=m \
+ CONFIG_MPLS_ROUTING=m \
+ CONFIG_MPLS_IPTUNNEL=m
+ FILES:= \
+ $(LINUX_DIR)/net/mpls/mpls_gso.ko \
+ $(LINUX_DIR)/net/mpls/mpls_iptunnel.ko \
+ $(LINUX_DIR)/net/mpls/mpls_router.ko
+ AUTOLOAD:=$(call AutoLoad,30,mpls_router mpls_iptunnel mpls_gso)
+endef
+
+define KernelPackage/mpls/description
+ Kernel support for MPLS
+endef
+
+$(eval $(call KernelPackage,mpls))