summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.39/004-ar71xx_spi_controller.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.39/004-ar71xx_spi_controller.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.39/004-ar71xx_spi_controller.patch26
1 files changed, 0 insertions, 26 deletions
diff --git a/target/linux/ar71xx/patches-2.6.39/004-ar71xx_spi_controller.patch b/target/linux/ar71xx/patches-2.6.39/004-ar71xx_spi_controller.patch
deleted file mode 100644
index d788016cc2..0000000000
--- a/target/linux/ar71xx/patches-2.6.39/004-ar71xx_spi_controller.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- a/drivers/spi/Kconfig
-+++ b/drivers/spi/Kconfig
-@@ -67,6 +67,13 @@ config SPI_ATH79
- This enables support for the SPI controller present on the
- Atheros AR71XX/AR724X/AR913X SoCs.
-
-+config SPI_AR71XX
-+ tristate "Atheros AR71xx SPI Controller"
-+ depends on SPI_MASTER && ATHEROS_AR71XX
-+ select SPI_BITBANG
-+ help
-+ This is the SPI contoller driver for Atheros AR71xx.
-+
- config SPI_ATMEL
- tristate "Atmel SPI Controller"
- depends on (ARCH_AT91 || AVR32)
---- a/drivers/spi/Makefile
-+++ b/drivers/spi/Makefile
-@@ -10,6 +10,7 @@ obj-$(CONFIG_SPI_MASTER) += spi.o
-
- # SPI master controller drivers (bus)
- obj-$(CONFIG_SPI_ALTERA) += spi_altera.o
-+obj-$(CONFIG_SPI_AR71XX) += ar71xx_spi.o
- obj-$(CONFIG_SPI_ATMEL) += atmel_spi.o
- obj-$(CONFIG_SPI_ATH79) += ath79_spi.o
- obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.o