summaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/patches-3.14/112-bcm53xx-sprom-add-sprom-driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm53xx/patches-3.14/112-bcm53xx-sprom-add-sprom-driver.patch')
-rw-r--r--target/linux/bcm53xx/patches-3.14/112-bcm53xx-sprom-add-sprom-driver.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/bcm53xx/patches-3.14/112-bcm53xx-sprom-add-sprom-driver.patch b/target/linux/bcm53xx/patches-3.14/112-bcm53xx-sprom-add-sprom-driver.patch
index 739d8cf90d..e316a661ea 100644
--- a/target/linux/bcm53xx/patches-3.14/112-bcm53xx-sprom-add-sprom-driver.patch
+++ b/target/linux/bcm53xx/patches-3.14/112-bcm53xx-sprom-add-sprom-driver.patch
@@ -42,9 +42,9 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
+};
--- a/drivers/misc/Kconfig
+++ b/drivers/misc/Kconfig
-@@ -520,6 +520,17 @@ config BCM47XX_NVRAM
- help
- This adds support for the brcm47xx nvram driver.
+@@ -515,6 +515,17 @@ config SRAM
+ the genalloc API. It is supposed to be used for small on-chip SRAM
+ areas found on many SoCs.
+config BCM47XX_SPROM
+ tristate "BCM47XX sprom driver"
@@ -62,8 +62,8 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
source "drivers/misc/cb710/Kconfig"
--- a/drivers/misc/Makefile
+++ b/drivers/misc/Makefile
-@@ -55,3 +55,4 @@ obj-$(CONFIG_SRAM) += sram.o
+@@ -54,3 +54,4 @@ obj-$(CONFIG_LATTICE_ECP3_CONFIG) += lat
+ obj-$(CONFIG_SRAM) += sram.o
obj-y += mic/
obj-$(CONFIG_GENWQE) += genwqe/
- obj-$(CONFIG_BCM47XX_NVRAM) += bcm47xx-nvram.o
+obj-$(CONFIG_BCM47XX_SPROM) += bcm47xx-sprom.o