summaryrefslogtreecommitdiffstats
path: root/target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch')
-rw-r--r--target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch45
1 files changed, 0 insertions, 45 deletions
diff --git a/target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch b/target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch
deleted file mode 100644
index cb26ec83d4..0000000000
--- a/target/linux/imx6/patches-3.10/010-pcie-backport-fixes.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- a/arch/arm/boot/dts/imx6qdl.dtsi
-+++ b/arch/arm/boot/dts/imx6qdl.dtsi
-@@ -119,7 +119,7 @@
- 0x82000000 0 0x01000000 0x01000000 0 0x00f00000>; /* non-prefetchable memory */
- num-lanes = <1>;
- interrupts = <0 123 0x04>;
-- clocks = <&clks 189>, <&clks 187>, <&clks 206>, <&clks 144>;
-+ clocks = <&clks 189>, <&clks 187>, <&clks 198>, <&clks 144>;
- clock-names = "pcie_ref_125m", "sata_ref_100m", "lvds_gate", "pcie_axi";
- status = "disabled";
- };
---- a/drivers/pci/Kconfig
-+++ b/drivers/pci/Kconfig
-@@ -125,3 +125,5 @@ config PCI_IOAPIC
- config PCI_LABEL
- def_bool y if (DMI || ACPI)
- select NLS
-+
-+source "drivers/pci/host/Kconfig"
---- a/drivers/pci/Makefile
-+++ b/drivers/pci/Makefile
-@@ -67,3 +67,6 @@ obj-$(CONFIG_XEN_PCIDEV_FRONTEND) += xen
- obj-$(CONFIG_OF) += of.o
-
- ccflags-$(CONFIG_PCI_DEBUG) := -DDEBUG
-+
-+# PCI host controller drivers
-+obj-y += host/
---- a/Documentation/devicetree/bindings/clock/imx6q-clock.txt
-+++ b/Documentation/devicetree/bindings/clock/imx6q-clock.txt
-@@ -208,10 +208,10 @@ clocks and IDs.
- pll4_post_div 193
- pll5_post_div 194
- pll5_video_div 195
-- lvds1_sel 204
-- lvds2_sel 205
-- lvds1_gate 206
-- lvds2_gate 207
-+ lvds1_sel 196
-+ lvds2_sel 197
-+ lvds1_gate 198
-+ lvds2_gate 199
-
- Examples:
-