summaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/patches-2.6.26/120-compex_support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ixp4xx/patches-2.6.26/120-compex_support.patch')
-rw-r--r--target/linux/ixp4xx/patches-2.6.26/120-compex_support.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/ixp4xx/patches-2.6.26/120-compex_support.patch b/target/linux/ixp4xx/patches-2.6.26/120-compex_support.patch
index 689d7a3c70..9f309a6fa6 100644
--- a/target/linux/ixp4xx/patches-2.6.26/120-compex_support.patch
+++ b/target/linux/ixp4xx/patches-2.6.26/120-compex_support.patch
@@ -1,8 +1,8 @@
--- a/arch/arm/mach-ixp4xx/Kconfig
+++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -65,6 +65,14 @@
- Engineering Pronghorn Metro Platform. For more
- information on this platform, see <file:Documentation/arm/IXP4xx>.
+@@ -83,6 +83,14 @@
+ depends on MACH_PRONGHORN
+ default y
+config MACH_COMPEX
+ bool "Compex WP18 / NP18A"
@@ -17,18 +17,18 @@
help
--- a/arch/arm/mach-ixp4xx/Makefile
+++ b/arch/arm/mach-ixp4xx/Makefile
-@@ -17,6 +17,7 @@
+@@ -18,6 +18,7 @@
obj-pci-$(CONFIG_MACH_WG302V2) += wg302v2-pci.o
obj-pci-$(CONFIG_MACH_FSG) += fsg-pci.o
- obj-pci-$(CONFIG_MACH_PRONGHORNMETRO) += pronghornmetro-pci.o
+ obj-pci-$(CONFIG_MACH_PRONGHORN) += pronghorn-pci.o
+obj-pci-$(CONFIG_MACH_COMPEX) += ixdp425-pci.o
obj-y += common.o
-@@ -32,6 +33,7 @@
+@@ -34,6 +35,7 @@
obj-$(CONFIG_MACH_WG302V2) += wg302v2-setup.o
obj-$(CONFIG_MACH_FSG) += fsg-setup.o
- obj-$(CONFIG_MACH_PRONGHORNMETRO) += pronghornmetro-setup.o
+ obj-$(CONFIG_MACH_PRONGHORN) += pronghorn-setup.o
+obj-$(CONFIG_MACH_COMPEX) += compex-setup.o
obj-$(CONFIG_PCI) += $(obj-pci-$(CONFIG_PCI)) common-pci.o