summaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-3.2/0001-GPIO-add-bindings-for-managed-devices.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/patches-3.2/0001-GPIO-add-bindings-for-managed-devices.patch')
-rw-r--r--target/linux/lantiq/patches-3.2/0001-GPIO-add-bindings-for-managed-devices.patch144
1 files changed, 144 insertions, 0 deletions
diff --git a/target/linux/lantiq/patches-3.2/0001-GPIO-add-bindings-for-managed-devices.patch b/target/linux/lantiq/patches-3.2/0001-GPIO-add-bindings-for-managed-devices.patch
new file mode 100644
index 0000000000..316d040d49
--- /dev/null
+++ b/target/linux/lantiq/patches-3.2/0001-GPIO-add-bindings-for-managed-devices.patch
@@ -0,0 +1,144 @@
+From 282f1ca84b35f3be68abc4fd8b52e229f3cb6bb7 Mon Sep 17 00:00:00 2001
+From: John Crispin <blogic@openwrt.org>
+Date: Thu, 8 Mar 2012 13:23:53 +0100
+Subject: [PATCH 01/70] GPIO: add bindings for managed devices
+
+This patch adds 2 functions that allow managed devices to request GPIOs.
+These GPIOs will then be managed by drivers/base/devres.c.
+
+Signed-off-by: John Crispin <blogic@openwrt.org>
+Signed-off-by: Grant Likely <grant.likely@secretlab.ca>
+---
+ drivers/gpio/Makefile | 2 +-
+ drivers/gpio/devres.c | 90 ++++++++++++++++++++++++++++++++++++++++++++
+ include/asm-generic/gpio.h | 4 ++
+ 3 files changed, 95 insertions(+), 1 deletions(-)
+ create mode 100644 drivers/gpio/devres.c
+
+diff --git a/drivers/gpio/Makefile b/drivers/gpio/Makefile
+index 4e018d6..76dbd3f 100644
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -2,7 +2,7 @@
+
+ ccflags-$(CONFIG_DEBUG_GPIO) += -DDEBUG
+
+-obj-$(CONFIG_GPIOLIB) += gpiolib.o
++obj-$(CONFIG_GPIOLIB) += gpiolib.o devres.o
+
+ # Device drivers. Generally keep list sorted alphabetically
+ obj-$(CONFIG_GPIO_GENERIC) += gpio-generic.o
+diff --git a/drivers/gpio/devres.c b/drivers/gpio/devres.c
+new file mode 100644
+index 0000000..3dd2939
+--- /dev/null
++++ b/drivers/gpio/devres.c
+@@ -0,0 +1,90 @@
++/*
++ * drivers/gpio/devres.c - managed gpio resources
++ *
++ * This program is free software; you can redistribute it and/or modify
++ * it under the terms of the GNU General Public License version 2
++ * as published by the Free Software Foundation.
++ *
++ * You should have received a copy of the GNU General Public License
++ * along with this program; if not, write to the Free Software
++ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
++ *
++ * This file is based on kernel/irq/devres.c
++ *
++ * Copyright (c) 2011 John Crispin <blogic@openwrt.org>
++ */
++
++#include <linux/module.h>
++#include <linux/gpio.h>
++#include <linux/device.h>
++#include <linux/gfp.h>
++
++static void devm_gpio_release(struct device *dev, void *res)
++{
++ unsigned *gpio = res;
++
++ gpio_free(*gpio);
++}
++
++static int devm_gpio_match(struct device *dev, void *res, void *data)
++{
++ unsigned *this = res, *gpio = data;
++
++ return *this == *gpio;
++}
++
++/**
++ * devm_gpio_request - request a gpio for a managed device
++ * @dev: device to request the gpio for
++ * @gpio: gpio to allocate
++ * @label: the name of the requested gpio
++ *
++ * Except for the extra @dev argument, this function takes the
++ * same arguments and performs the same function as
++ * gpio_request(). GPIOs requested with this function will be
++ * automatically freed on driver detach.
++ *
++ * If an GPIO allocated with this function needs to be freed
++ * separately, devm_gpio_free() must be used.
++ */
++
++int devm_gpio_request(struct device *dev, unsigned gpio, const char *label)
++{
++ unsigned *dr;
++ int rc;
++
++ dr = devres_alloc(devm_gpio_release, sizeof(unsigned), GFP_KERNEL);
++ if (!dr)
++ return -ENOMEM;
++
++ rc = gpio_request(gpio, label);
++ if (rc) {
++ devres_free(dr);
++ return rc;
++ }
++
++ *dr = gpio;
++ devres_add(dev, dr);
++
++ return 0;
++}
++EXPORT_SYMBOL(devm_gpio_request);
++
++/**
++ * devm_gpio_free - free an interrupt
++ * @dev: device to free gpio for
++ * @gpio: gpio to free
++ *
++ * Except for the extra @dev argument, this function takes the
++ * same arguments and performs the same function as gpio_free().
++ * This function instead of gpio_free() should be used to manually
++ * free GPIOs allocated with devm_gpio_request().
++ */
++void devm_gpio_free(struct device *dev, unsigned int gpio)
++{
++
++ WARN_ON(devres_destroy(dev, devm_gpio_release, devm_gpio_match,
++ &gpio));
++ gpio_free(gpio);
++}
++EXPORT_SYMBOL(devm_gpio_free);
+diff --git a/include/asm-generic/gpio.h b/include/asm-generic/gpio.h
+index 8c86210..8601a02 100644
+--- a/include/asm-generic/gpio.h
++++ b/include/asm-generic/gpio.h
+@@ -175,6 +175,10 @@ extern int gpio_request_one(unsigned gpio, unsigned long flags, const char *labe
+ extern int gpio_request_array(const struct gpio *array, size_t num);
+ extern void gpio_free_array(const struct gpio *array, size_t num);
+
++/* bindings for managed devices that want to request gpios */
++int devm_gpio_request(struct device *dev, unsigned gpio, const char *label);
++void devm_gpio_free(struct device *dev, unsigned int gpio);
++
+ #ifdef CONFIG_GPIO_SYSFS
+
+ /*
+--
+1.7.7.1
+