summaryrefslogtreecommitdiffstats
path: root/target/linux/uml/patches-4.1
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/uml/patches-4.1')
-rw-r--r--target/linux/uml/patches-4.1/001-um-Stop-abusing-__KERNEL__.patch94
-rw-r--r--target/linux/uml/patches-4.1/002-um-Remove-copy-paste-code-from-init.h.patch44
-rw-r--r--target/linux/uml/patches-4.1/101-mconsole-exec.patch211
-rw-r--r--target/linux/uml/patches-4.1/102-pseudo-random-mac.patch124
4 files changed, 0 insertions, 473 deletions
diff --git a/target/linux/uml/patches-4.1/001-um-Stop-abusing-__KERNEL__.patch b/target/linux/uml/patches-4.1/001-um-Stop-abusing-__KERNEL__.patch
deleted file mode 100644
index a46a5be406..0000000000
--- a/target/linux/uml/patches-4.1/001-um-Stop-abusing-__KERNEL__.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-From: Richard Weinberger <richard@nod.at>
-Date: Sun, 31 May 2015 19:50:57 +0200
-Subject: [PATCH] um: Stop abusing __KERNEL__
-
-Currently UML is abusing __KERNEL__ to distinguish between
-kernel and host code (os-Linux). It is better to use a custom
-define such that existing users of __KERNEL__ don't get confused.
-
-Signed-off-by: Richard Weinberger <richard@nod.at>
----
-
---- a/arch/um/drivers/mconsole.h
-+++ b/arch/um/drivers/mconsole.h
-@@ -7,7 +7,7 @@
- #ifndef __MCONSOLE_H__
- #define __MCONSOLE_H__
-
--#ifndef __KERNEL__
-+#ifdef __UM_HOST__
- #include <stdint.h>
- #define u32 uint32_t
- #endif
---- a/arch/um/include/shared/init.h
-+++ b/arch/um/include/shared/init.h
-@@ -40,7 +40,7 @@
- typedef int (*initcall_t)(void);
- typedef void (*exitcall_t)(void);
-
--#ifndef __KERNEL__
-+#ifdef __UM_HOST__
- #ifndef __section
- # define __section(S) __attribute__ ((__section__(#S)))
- #endif
-@@ -131,7 +131,7 @@ extern struct uml_param __uml_setup_star
- #define __uml_postsetup_call __used __section(.uml.postsetup.init)
- #define __uml_exit_call __used __section(.uml.exitcall.exit)
-
--#ifndef __KERNEL__
-+#ifdef __UM_HOST__
-
- #define __define_initcall(level,fn) \
- static initcall_t __initcall_##fn __used \
---- a/arch/um/include/shared/user.h
-+++ b/arch/um/include/shared/user.h
-@@ -17,7 +17,7 @@
- #define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]))
-
- /* This is to get size_t */
--#ifdef __KERNEL__
-+#ifndef __UM_HOST__
- #include <linux/types.h>
- #else
- #include <stddef.h>
---- a/arch/um/Makefile
-+++ b/arch/um/Makefile
-@@ -68,9 +68,10 @@ KBUILD_CFLAGS += $(CFLAGS) $(CFLAGS-y) -
-
- KBUILD_AFLAGS += $(ARCH_INCLUDE)
-
--USER_CFLAGS = $(patsubst $(KERNEL_DEFINES),,$(patsubst -D__KERNEL__,,\
-- $(patsubst -I%,,$(KBUILD_CFLAGS)))) $(ARCH_INCLUDE) $(MODE_INCLUDE) \
-- $(filter -I%,$(CFLAGS)) -D_FILE_OFFSET_BITS=64 -idirafter include
-+USER_CFLAGS = $(patsubst $(KERNEL_DEFINES),,$(patsubst -I%,,$(KBUILD_CFLAGS))) \
-+ $(ARCH_INCLUDE) $(MODE_INCLUDE) $(filter -I%,$(CFLAGS)) \
-+ -D_FILE_OFFSET_BITS=64 -idirafter include \
-+ -D__KERNEL__ -D__UM_HOST__
-
- #This will adjust *FLAGS accordingly to the platform.
- include $(ARCH_DIR)/Makefile-os-$(OS)
---- a/arch/x86/um/shared/sysdep/tls.h
-+++ b/arch/x86/um/shared/sysdep/tls.h
-@@ -1,7 +1,7 @@
- #ifndef _SYSDEP_TLS_H
- #define _SYSDEP_TLS_H
-
--# ifndef __KERNEL__
-+#ifdef __UM_HOST__
-
- /* Change name to avoid conflicts with the original one from <asm/ldt.h>, which
- * may be named user_desc (but in 2.4 and in header matching its API was named
-@@ -22,11 +22,11 @@ typedef struct um_dup_user_desc {
- #endif
- } user_desc_t;
-
--# else /* __KERNEL__ */
-+#else /* __UM_HOST__ */
-
- typedef struct user_desc user_desc_t;
-
--# endif /* __KERNEL__ */
-+#endif /* __UM_HOST__ */
-
- extern int os_set_thread_area(user_desc_t *info, int pid);
- extern int os_get_thread_area(user_desc_t *info, int pid);
diff --git a/target/linux/uml/patches-4.1/002-um-Remove-copy-paste-code-from-init.h.patch b/target/linux/uml/patches-4.1/002-um-Remove-copy-paste-code-from-init.h.patch
deleted file mode 100644
index 6733384b91..0000000000
--- a/target/linux/uml/patches-4.1/002-um-Remove-copy-paste-code-from-init.h.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From: Richard Weinberger <richard@nod.at>
-Date: Sun, 31 May 2015 22:15:58 +0200
-Subject: [PATCH] um: Remove copy&paste code from init.h
-
-As we got rid of the __KERNEL__ abuse, we can directly
-include linux/compiler.h now.
-This also allows gcc 5 to build UML.
-
-Reported-by: Hans-Werner Hilse <hwhilse@gmail.com>
-Signed-off-by: Richard Weinberger <richard@nod.at>
----
-
---- a/arch/um/include/shared/init.h
-+++ b/arch/um/include/shared/init.h
-@@ -40,28 +40,8 @@
- typedef int (*initcall_t)(void);
- typedef void (*exitcall_t)(void);
-
--#ifdef __UM_HOST__
--#ifndef __section
--# define __section(S) __attribute__ ((__section__(#S)))
--#endif
--
--#if __GNUC__ == 3
--
--#if __GNUC_MINOR__ >= 3
--# define __used __attribute__((__used__))
--#else
--# define __used __attribute__((__unused__))
--#endif
--
--#else
--#if __GNUC__ == 4
--# define __used __attribute__((__used__))
--#endif
--#endif
--
--#else
- #include <linux/compiler.h>
--#endif
-+
- /* These are for everybody (although not all archs will actually
- discard it in modules) */
- #define __init __section(.init.text)
diff --git a/target/linux/uml/patches-4.1/101-mconsole-exec.patch b/target/linux/uml/patches-4.1/101-mconsole-exec.patch
deleted file mode 100644
index ac300a9293..0000000000
--- a/target/linux/uml/patches-4.1/101-mconsole-exec.patch
+++ /dev/null
@@ -1,211 +0,0 @@
-#
-# Minimalist mconsole exec patch
-#
-# 3.10 version (with bit more synchronous behavior) by fingon at iki dot fi
-# Adaptation to kernel 3.3.8 made by David Fernández (david at dit.upm.es) for
-# Starting point: mconsole-exec-2.6.30.patch for kernel 2.6.30
-# Author of original patch: Paolo Giarrusso, aka Blaisorblade
-# (http://www.user-mode-linux.org/~blaisorblade)
-#
-# Known misfeatures:
-#
-# - If output is too long, blocks (and breaks horribly)
-# (this misfeature from 3.10 patches, when minimalizing the patch;
-# workaround: redirect to a shared filesystem if long output is expected)
-#
-# - Nothing useful is done with stdin
-#
---- a/arch/um/drivers/mconsole.h
-+++ b/arch/um/drivers/mconsole.h
-@@ -85,6 +85,7 @@ extern void mconsole_cad(struct mc_reque
- extern void mconsole_stop(struct mc_request *req);
- extern void mconsole_go(struct mc_request *req);
- extern void mconsole_log(struct mc_request *req);
-+extern void mconsole_exec(struct mc_request *req);
- extern void mconsole_proc(struct mc_request *req);
- extern void mconsole_stack(struct mc_request *req);
-
---- a/arch/um/drivers/mconsole_kern.c
-+++ b/arch/um/drivers/mconsole_kern.c
-@@ -4,6 +4,7 @@
- * Licensed under the GPL
- */
-
-+#include "linux/kmod.h"
- #include <linux/console.h>
- #include <linux/ctype.h>
- #include <linux/string.h>
-@@ -24,6 +25,7 @@
- #include <linux/fs.h>
- #include <linux/mount.h>
- #include <linux/file.h>
-+#include <linux/completion.h>
- #include <asm/uaccess.h>
- #include <asm/switch_to.h>
-
-@@ -121,6 +123,59 @@ void mconsole_log(struct mc_request *req
- mconsole_reply(req, "", 0, 0);
- }
-
-+void mconsole_exec(struct mc_request *req)
-+{
-+ struct subprocess_info *sub_info;
-+ int res, len;
-+ struct file *out;
-+ char buf[MCONSOLE_MAX_DATA];
-+
-+ char *envp[] = {
-+ "HOME=/", "TERM=linux",
-+ "PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin",
-+ NULL
-+ };
-+ char *argv[] = {
-+ "/bin/sh", "-c",
-+ req->request.data + strlen("exec "),
-+ NULL
-+ };
-+
-+ sub_info = call_usermodehelper_setup("/bin/sh", argv, envp, GFP_ATOMIC, NULL, NULL, NULL);
-+ if (sub_info == NULL) {
-+ mconsole_reply(req, "call_usermodehelper_setup failed", 1, 0);
-+ return;
-+ }
-+ res = call_usermodehelper_stdoutpipe(sub_info, &out);
-+ if (res < 0) {
-+ kfree(sub_info);
-+ mconsole_reply(req, "call_usermodehelper_stdoutpipe failed", 1, 0);
-+ return;
-+ }
-+
-+ res = call_usermodehelper_exec(sub_info, UMH_WAIT_PROC);
-+ if (res < 0) {
-+ kfree(sub_info);
-+ mconsole_reply(req, "call_usermodehelper_exec failed", 1, 0);
-+ return;
-+ }
-+
-+ for (;;) {
-+ len = out->f_op->read(out, buf, sizeof(buf), &out->f_pos);
-+ if (len < 0) {
-+ mconsole_reply(req, "reading output failed", 1, 0);
-+ break;
-+ }
-+ if (len == 0)
-+ break;
-+ mconsole_reply_len(req, buf, len, 0, 1);
-+ }
-+ fput(out);
-+
-+ mconsole_reply_len(req, NULL, 0, 0, 0);
-+}
-+
-+
- void mconsole_proc(struct mc_request *req)
- {
- struct vfsmount *mnt = task_active_pid_ns(current)->proc_mnt;
-@@ -187,6 +242,7 @@ void mconsole_proc(struct mc_request *re
- stop - pause the UML; it will do nothing until it receives a 'go' \n\
- go - continue the UML after a 'stop' \n\
- log <string> - make UML enter <string> into the kernel log\n\
-+ exec <string> - pass <string> to /bin/sh -c synchronously\n\
- proc <file> - returns the contents of the UML's /proc/<file>\n\
- stack <pid> - returns the stack of the specified pid\n\
- "
---- a/arch/um/drivers/mconsole_user.c
-+++ b/arch/um/drivers/mconsole_user.c
-@@ -30,6 +30,7 @@ static struct mconsole_command commands[
- { "stop", mconsole_stop, MCONSOLE_PROC },
- { "go", mconsole_go, MCONSOLE_INTR },
- { "log", mconsole_log, MCONSOLE_INTR },
-+ { "exec", mconsole_exec, MCONSOLE_PROC },
- { "proc", mconsole_proc, MCONSOLE_PROC },
- { "stack", mconsole_stack, MCONSOLE_INTR },
- };
---- a/arch/um/os-Linux/file.c
-+++ b/arch/um/os-Linux/file.c
-@@ -534,6 +534,8 @@ int os_create_unix_socket(const char *fi
-
- addr.sun_family = AF_UNIX;
-
-+ if (len > sizeof(addr.sun_path))
-+ len = sizeof(addr.sun_path);
- snprintf(addr.sun_path, len, "%s", file);
-
- err = bind(sock, (struct sockaddr *) &addr, sizeof(addr));
---- a/include/linux/kmod.h
-+++ b/include/linux/kmod.h
-@@ -62,6 +62,7 @@ struct subprocess_info {
- int wait;
- int retval;
- int (*init)(struct subprocess_info *info, struct cred *new);
-+ struct file *stdout;
- void (*cleanup)(struct subprocess_info *info);
- void *data;
- };
-@@ -104,4 +105,6 @@ extern int usermodehelper_read_trylock(v
- extern long usermodehelper_read_lock_wait(long timeout);
- extern void usermodehelper_read_unlock(void);
-
-+int call_usermodehelper_stdoutpipe(struct subprocess_info *sub_info, struct file **filp);
-+
- #endif /* __LINUX_KMOD_H__ */
---- a/kernel/kmod.c
-+++ b/kernel/kmod.c
-@@ -39,6 +39,7 @@
- #include <linux/rwsem.h>
- #include <linux/ptrace.h>
- #include <linux/async.h>
-+#include <linux/pipe_fs_i.h>
- #include <asm/uaccess.h>
-
- #include <trace/events/module.h>
-@@ -223,6 +224,28 @@ static int ____call_usermodehelper(void
- flush_signal_handlers(current, 1);
- spin_unlock_irq(&current->sighand->siglock);
-
-+ /* Install output when needed */
-+ if (sub_info->stdout) {
-+ struct files_struct *f = current->files;
-+ struct fdtable *fdt;
-+
-+ sys_close(1);
-+ sys_close(2);
-+ get_file(sub_info->stdout);
-+ fd_install(1, sub_info->stdout);
-+ fd_install(2, sub_info->stdout);
-+ spin_lock(&f->file_lock);
-+ fdt = files_fdtable(f);
-+ __set_bit(1, fdt->open_fds);
-+ __clear_bit(1, fdt->close_on_exec);
-+ __set_bit(2, fdt->open_fds);
-+ __clear_bit(2, fdt->close_on_exec);
-+ spin_unlock(&f->file_lock);
-+
-+ /* disallow core files */
-+ current->signal->rlim[RLIMIT_CORE] = (struct rlimit){0, 0};
-+ }
-+
- /* We can run anywhere, unlike our parent keventd(). */
- set_cpus_allowed_ptr(current, cpu_all_mask);
-
-@@ -522,6 +545,20 @@ struct subprocess_info *call_usermodehel
- }
- EXPORT_SYMBOL(call_usermodehelper_setup);
-
-+int call_usermodehelper_stdoutpipe(struct subprocess_info *sub_info,
-+ struct file **filp)
-+{
-+ struct file *f[2];
-+
-+ if (create_pipe_files(f, 0)<0)
-+ return PTR_ERR(f);
-+ sub_info->stdout = f[1];
-+ *filp = f[0];
-+ return 0;
-+}
-+EXPORT_SYMBOL(call_usermodehelper_stdoutpipe);
-+
-+
- /**
- * call_usermodehelper_exec - start a usermode application
- * @sub_info: information about the subprocessa
diff --git a/target/linux/uml/patches-4.1/102-pseudo-random-mac.patch b/target/linux/uml/patches-4.1/102-pseudo-random-mac.patch
deleted file mode 100644
index fc54f603c0..0000000000
--- a/target/linux/uml/patches-4.1/102-pseudo-random-mac.patch
+++ /dev/null
@@ -1,124 +0,0 @@
-===============================================================================
-
-This patch makes MAC addresses of network interfaces predictable. In
-particular, it adds a small routine that computes MAC addresses of based on
-a SHA1 hash of the virtual machine name and interface ID.
-
-TECHNICAL INFORMATION:
-
-Applies to vanilla kernel 3.9.4.
-
-===============================================================================
---- a/arch/um/Kconfig.net
-+++ b/arch/um/Kconfig.net
-@@ -21,6 +21,19 @@ config UML_NET
- enable at least one of the following transport options to actually
- make use of UML networking.
-
-+config UML_NET_RANDOM_MAC
-+ bool "Use random MAC addresses for network interfaces"
-+ default n
-+ depends on UML_NET
-+ help
-+ Virtual network devices inside a User-Mode Linux instance must be
-+ assigned a MAC (Ethernet) address. If none is specified on the UML
-+ command line, one must be automatically computed. If this option is
-+ enabled, a randomly generated address is used. Otherwise, if this
-+ option is disabled, the address is generated from a SHA1 hash of
-+ the umid of the UML instance and the interface name. The latter choice
-+ is useful to make MAC addresses predictable.
-+
- config UML_NET_ETHERTAP
- bool "Ethertap transport"
- depends on UML_NET
---- a/arch/um/drivers/net_kern.c
-+++ b/arch/um/drivers/net_kern.c
-@@ -25,6 +25,13 @@
- #include <net_kern.h>
- #include <net_user.h>
-
-+#include <crypto/sha.h>
-+#include <linux/string.h>
-+#include <linux/crypto.h>
-+#include <linux/err.h>
-+#include <linux/scatterlist.h>
-+#include "os.h"
-+
- #define DRIVER_NAME "uml-netdev"
-
- static DEFINE_SPINLOCK(opened_lock);
-@@ -295,11 +302,47 @@ static void uml_net_user_timer_expire(un
- #endif
- }
-
-+#ifndef CONFIG_UML_NET_RANDOM_MAC
-+
-+/* Compute a SHA1 hash of the UML instance's id and
-+ * * an interface name. */
-+static int compute_hash(const char *umid, const char *ifname, char *hash) {
-+ char vmif[1024];
-+ struct scatterlist sg;
-+ struct crypto_hash *tfm;
-+ struct hash_desc desc;
-+
-+ strcpy (vmif, umid);
-+ strcat (vmif, ifname);
-+
-+ tfm = crypto_alloc_hash("sha1", 0, CRYPTO_ALG_ASYNC);
-+ if (IS_ERR(tfm))
-+ return 1;
-+
-+ desc.tfm = tfm;
-+ desc.flags = 0;
-+
-+ sg_init_table(&sg, 1);
-+ sg_set_buf(&sg, vmif, strlen(vmif));
-+
-+ if (crypto_hash_digest(&desc, &sg, strlen(vmif), hash)) {
-+ crypto_free_hash(tfm);
-+ return 1;
-+ }
-+
-+ crypto_free_hash(tfm);
-+
-+ return 0;
-+}
-+
-+#endif
-+
- static void setup_etheraddr(struct net_device *dev, char *str)
- {
- unsigned char *addr = dev->dev_addr;
- char *end;
- int i;
-+ u8 hash[SHA1_DIGEST_SIZE];
-
- if (str == NULL)
- goto random;
-@@ -340,9 +383,26 @@ static void setup_etheraddr(struct net_d
- return;
-
- random:
-+#ifdef CONFIG_UML_NET_RANDOM_MAC
- printk(KERN_INFO
- "Choosing a random ethernet address for device %s\n", dev->name);
- eth_hw_addr_random(dev);
-+#else
-+ printk(KERN_INFO
-+ "Computing a digest to use as ethernet address for device %s\n", dev->name);
-+ if (compute_hash(get_umid(), dev->name, hash)) {
-+ printk(KERN_WARNING
-+ "Could not compute digest to use as ethernet address for device %s. "
-+ "Using random address instead.\n", dev->name);
-+ random_ether_addr(addr);
-+ }
-+ else {
-+ for (i=0; i < 6; i++)
-+ addr[i] = (hash[i] + hash[i+6]) % 0x100;
-+ }
-+ addr [0] &= 0xfe; /* clear multicast bit */
-+ addr [0] |= 0x02; /* set local assignment bit (IEEE802) */
-+#endif
- }
-
- static DEFINE_SPINLOCK(devices_lock);