summaryrefslogtreecommitdiffstats
path: root/target/linux/xburst/patches-2.6.35/015-kbuild.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/xburst/patches-2.6.35/015-kbuild.patch')
-rw-r--r--target/linux/xburst/patches-2.6.35/015-kbuild.patch94
1 files changed, 94 insertions, 0 deletions
diff --git a/target/linux/xburst/patches-2.6.35/015-kbuild.patch b/target/linux/xburst/patches-2.6.35/015-kbuild.patch
new file mode 100644
index 0000000000..d10b7ec188
--- /dev/null
+++ b/target/linux/xburst/patches-2.6.35/015-kbuild.patch
@@ -0,0 +1,94 @@
+From a486767b412d7f19a02ef704cc60e4bc79404633 Mon Sep 17 00:00:00 2001
+From: Lars-Peter Clausen <lars@metafoo.de>
+Date: Wed, 2 Jun 2010 21:10:30 +0200
+Subject: [PATCH] MIPS: JZ4740: Add Kbuild files
+
+This patch adds the Kbuild files for the JZ4740 architecture and adds JZ4740
+support to the MIPS Kbuild files.
+
+Signed-off-by: Lars-Peter Clausen <lars@metafoo.de>
+---
+ arch/mips/Kconfig | 13 +++++++++++++
+ arch/mips/Makefile | 6 ++++++
+ arch/mips/jz4740/Kconfig | 8 ++++++++
+ arch/mips/jz4740/Makefile | 18 ++++++++++++++++++
+ 4 files changed, 45 insertions(+), 0 deletions(-)
+ create mode 100644 arch/mips/jz4740/Kconfig
+ create mode 100644 arch/mips/jz4740/Makefile
+
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -162,6 +162,18 @@ config MACH_JAZZ
+ Members include the Acer PICA, MIPS Magnum 4000, MIPS Millennium and
+ Olivetti M700-10 workstations.
+
++config MACH_JZ4740
++ bool "Ingenic JZ4740 based machines"
++ select SYS_HAS_CPU_MIPS32_R1
++ select SYS_SUPPORTS_32BIT_KERNEL
++ select SYS_SUPPORTS_LITTLE_ENDIAN
++ select DMA_NONCOHERENT
++ select IRQ_CPU
++ select GENERIC_GPIO
++ select ARCH_REQUIRE_GPIOLIB
++ select SYS_HAS_EARLY_PRINTK
++ select HAVE_PWM
++
+ config LASAT
+ bool "LASAT Networks platforms"
+ select CEVT_R4K
+@@ -686,6 +698,7 @@ endchoice
+ source "arch/mips/alchemy/Kconfig"
+ source "arch/mips/bcm63xx/Kconfig"
+ source "arch/mips/jazz/Kconfig"
++source "arch/mips/jz4740/Kconfig"
+ source "arch/mips/lasat/Kconfig"
+ source "arch/mips/pmc-sierra/Kconfig"
+ source "arch/mips/powertv/Kconfig"
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -661,6 +661,12 @@ else
+ load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
+ endif
+
++# Ingenic JZ4740
++#
++core-$(CONFIG_MACH_JZ4740) += arch/mips/jz4740/
++cflags-$(CONFIG_MACH_JZ4740) += -I$(srctree)/arch/mips/include/asm/mach-jz4740
++load-$(CONFIG_MACH_JZ4740) += 0xffffffff80010000
++
+ cflags-y += -I$(srctree)/arch/mips/include/asm/mach-generic
+ drivers-$(CONFIG_PCI) += arch/mips/pci/
+
+--- /dev/null
++++ b/arch/mips/jz4740/Kconfig
+@@ -0,0 +1,8 @@
++choice
++ prompt "Machine type"
++ depends on MACH_JZ4740
++
++endchoice
++
++config HAVE_PWM
++ bool
+--- /dev/null
++++ b/arch/mips/jz4740/Makefile
+@@ -0,0 +1,18 @@
++#
++# Makefile for the Ingenic JZ4740.
++#
++
++# Object file lists.
++
++obj-y += prom.o irq.o time.o reset.o setup.o dma.o \
++ gpio.o clock.o platform.o timer.o pwm.o serial.o
++
++obj-$(CONFIG_DEBUG_FS) += clock-debugfs.o
++
++# board specific support
++
++# PM support
++
++obj-$(CONFIG_PM) += pm.o
++
++EXTRA_CFLAGS += -Werror -Wall