summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/Makefile2
-rw-r--r--target/linux/Makefile3
2 files changed, 4 insertions, 1 deletions
diff --git a/target/Makefile b/target/Makefile
index 9a7dff2a78..438d268b5e 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -51,5 +51,5 @@ image_install: image_compile
imagebuilder_install: image_install
$(MAKE) -C imagebuilder install
-%-prereq %-prepare %-download %-clean %-compile %-install: FORCE
+%-prereq %-prepare %-download %-clean %-compile %-install %-refresh: FORCE
$(MAKE) -C $* $(patsubst $*-%,%,$@)
diff --git a/target/linux/Makefile b/target/linux/Makefile
index c15d81999f..275085448f 100644
--- a/target/linux/Makefile
+++ b/target/linux/Makefile
@@ -19,6 +19,9 @@ compile:
install:
$(MAKE) -C $(BOARD)-$(KERNEL) install
+refresh:
+ $(MAKE) -C $(BOARD)-$(KERNEL) refresh
+
menuconfig:
$(MAKE) -C $(BOARD)-$(KERNEL) menuconfig