From 2c2bf90a8ed8b0ae12367888d9a43a7c192073cc Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Tue, 27 Feb 2007 23:44:04 +0000
Subject: fix ccache build (#1415)

SVN-Revision: 6412
---
 toolchain/ccache/Makefile | 25 ++++++++++++++++---------
 1 file changed, 16 insertions(+), 9 deletions(-)

(limited to 'toolchain')

diff --git a/toolchain/ccache/Makefile b/toolchain/ccache/Makefile
index 348aed0fce..e8e85b442a 100644
--- a/toolchain/ccache/Makefile
+++ b/toolchain/ccache/Makefile
@@ -19,24 +19,31 @@ PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/host-build.mk
 
-ifneq ($(shell which ccache),)
-  define Build/Configure
-    	$(call Build/Configure/Default)
-  endef
-
+ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
   define Build/Compile
-    	$(MAKE) CC="$(HOSTCC)" -C $(PKG_BUILD_DIR)
+	$(MAKE) CC="$(HOSTCC)" -C $(PKG_BUILD_DIR)
   endef
 
   define Build/Install
-    	$(MAKE) -C $(PKG_BUILD_DIR) \
-   		DESTDIR="$(STAGING_DIR)" \
+	$(MAKE) -C $(PKG_BUILD_DIR) \
+		DESTDIR="$(STAGING_DIR)" \
 		install
   endef
 
   define Build/Clean
-	$(MAKE) -C $(PKG_BUILD_DIR) uninstall
+	-$(MAKE) -C $(PKG_BUILD_DIR) uninstall
 	-$(MAKE) -C $(PKG_BUILD_DIR) clean
+	$(call Build/Clean/Default)
+  endef
+else
+  define Build/Prepare
+  endef
+  define Build/Configure
+  endef
+  define Build/Compile
+  endef
+  define Build/Clean
   endef
 endif
+
 $(eval $(call HostBuild))
-- 
cgit v1.2.3