aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-03 08:58:14 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-03 08:58:14 +0000
commit2750423a702eac91d17015e541e321c657c72f18 (patch)
tree29fc1ebb2e89d2e529607ed463481241e55d09ce /include/kernel.mk
parent05a46c716e24adb817dd5e41ebdb0308ec6b78b2 (diff)
downloadmaster-187ad058-2750423a702eac91d17015e541e321c657c72f18.tar.gz
master-187ad058-2750423a702eac91d17015e541e321c657c72f18.tar.bz2
master-187ad058-2750423a702eac91d17015e541e321c657c72f18.zip
require all CONFIG_* symbols listed in its KCONFIG to be set to m in order to actually build a kmod package, tweak and fix kernel package definitions.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8591 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 519ea42d23..a0f256b998 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -104,7 +104,8 @@ $(call KernelPackage/$(1)/description)
endef
endif
- ifneq ($(if $(KCONFIG),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
+ # check that all CONFIG_* symbols in $(KCONFIG) are set to 'm'
+ ifeq ($(filter-out m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$(if $($(c)),$($(c)),n))),)
ifneq ($(strip $(FILES)),)
define Package/kmod-$(1)/install
mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)