aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/uqmi/Makefile2
-rwxr-xr-x[-rw-r--r--]package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/utils/uqmi/Makefile b/package/network/utils/uqmi/Makefile
index 16e7fea0a9..7ccf549989 100644
--- a/package/network/utils/uqmi/Makefile
+++ b/package/network/utils/uqmi/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uqmi
-PKG_VERSION:=2015-08-13
+PKG_VERSION:=2015-09-17
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
diff --git a/package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh b/package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh
index 8ee7dbdecf..48864bea4b 100644..100755
--- a/package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh
+++ b/package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh
@@ -140,7 +140,7 @@ proto_qmi_setup() {
return 1
}
- if [ -z "$dhcp" ]; then
+ if [ -z "$dhcp" -o "$dhcp" = 0 ]; then
echo "Setting up $ifname"
[ -n "$ipv4" ] && {
json_load "$(uqmi -s -d $device --set-client-id wds,$cid_4 --get-current-settings)"