aboutsummaryrefslogtreecommitdiffstats
path: root/target/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/Makefile b/target/Makefile
index e066fa9d39..24c34036de 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -16,6 +16,9 @@ clean: linux-clean utils-clean lzma-clean image_clean
image_clean:
rm -f $(BIN_DIR)/openwrt-*
+linux/package/%:
+ $(MAKE) -C $(TOPDIR)/target/linux $(patsubst linux/%,%,$@)
+
%-clean:
@$(TRACE) target/$(patsubst %-clean,%,$@)-clean
$(MAKE) -C $(patsubst %-clean,%,$@) clean
@@ -35,5 +38,4 @@ linux-imagebuilder:
@$(TRACE) target/linux/imagebuilder
$(MAKE) -C linux imagebuilder
-linux/package/%:
- $(MAKE) -C $(TOPDIR)/target/linux $(patsubst linux/%,%,$@)
+