From 3b4e201de87e3e3064f2b24cb838669b45b2798e Mon Sep 17 00:00:00 2001
From: Hauke Mehrtens <hauke@openwrt.org>
Date: Thu, 18 Aug 2011 12:54:12 +0000
Subject: kernel: update to version 3.0.3

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28043 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 include/kernel-version.mk                                             | 4 ++--
 target/linux/brcm47xx/Makefile                                        | 2 +-
 .../brcm47xx/patches-3.0/0015-ssb-add-serial-flash-support.patch      | 2 +-
 target/linux/brcm47xx/patches-3.0/220-bcm5354.patch                   | 2 +-
 target/linux/generic/patches-3.0/950-vm_exports.patch                 | 4 ++--
 target/linux/malta/Makefile                                           | 2 +-
 target/linux/orion/Makefile                                           | 2 +-
 target/linux/ppc40x/Makefile                                          | 2 +-
 target/linux/ppc44x/Makefile                                          | 2 +-
 target/linux/realview/Makefile                                        | 2 +-
 target/linux/uml/Makefile                                             | 2 +-
 11 files changed, 13 insertions(+), 13 deletions(-)

diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 530fae283b..1b41d84582 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -29,8 +29,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.39.4)
   LINUX_KERNEL_MD5SUM:=a17c748c2070168f1e784e9605ca043d
 endif
-ifeq ($(LINUX_VERSION),3.0.1)
-  LINUX_KERNEL_MD5SUM:=aed949984b878b7fb77ffe9cbee8ce0c
+ifeq ($(LINUX_VERSION),3.0.3)
+  LINUX_KERNEL_MD5SUM:=6a8af5f6733b3db970197e65b3db712c
 endif
 
 # disable the md5sum check for unknown kernel versions
diff --git a/target/linux/brcm47xx/Makefile b/target/linux/brcm47xx/Makefile
index 167d9e4ecb..ce5e8624c8 100644
--- a/target/linux/brcm47xx/Makefile
+++ b/target/linux/brcm47xx/Makefile
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
diff --git a/target/linux/brcm47xx/patches-3.0/0015-ssb-add-serial-flash-support.patch b/target/linux/brcm47xx/patches-3.0/0015-ssb-add-serial-flash-support.patch
index 1e7762b4b2..e91c2a44f4 100644
--- a/target/linux/brcm47xx/patches-3.0/0015-ssb-add-serial-flash-support.patch
+++ b/target/linux/brcm47xx/patches-3.0/0015-ssb-add-serial-flash-support.patch
@@ -601,7 +601,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
 +}
 --- a/drivers/ssb/driver_mipscore.c
 +++ b/drivers/ssb/driver_mipscore.c
-@@ -193,7 +193,13 @@ static void ssb_mips_flash_detect(struct
+@@ -203,7 +203,13 @@ static void ssb_mips_flash_detect(struct
  	switch (bus->chipco.capabilities & SSB_CHIPCO_CAP_FLASHT) {
  	case SSB_CHIPCO_FLASHT_STSER:
  	case SSB_CHIPCO_FLASHT_ATSER:
diff --git a/target/linux/brcm47xx/patches-3.0/220-bcm5354.patch b/target/linux/brcm47xx/patches-3.0/220-bcm5354.patch
index 7d7ca8e969..6055e0a738 100644
--- a/target/linux/brcm47xx/patches-3.0/220-bcm5354.patch
+++ b/target/linux/brcm47xx/patches-3.0/220-bcm5354.patch
@@ -20,7 +20,7 @@
  	switch (*plltype) {
 --- a/drivers/ssb/driver_mipscore.c
 +++ b/drivers/ssb/driver_mipscore.c
-@@ -234,6 +234,8 @@ u32 ssb_cpu_clock(struct ssb_mipscore *m
+@@ -241,6 +241,8 @@ u32 ssb_cpu_clock(struct ssb_mipscore *m
  
  	if ((pll_type == SSB_PLLTYPE_5) || (bus->chip_id == 0x5365)) {
  		rate = 200000000;
diff --git a/target/linux/generic/patches-3.0/950-vm_exports.patch b/target/linux/generic/patches-3.0/950-vm_exports.patch
index e1b88a0bb1..4be67a3a8e 100644
--- a/target/linux/generic/patches-3.0/950-vm_exports.patch
+++ b/target/linux/generic/patches-3.0/950-vm_exports.patch
@@ -89,7 +89,7 @@
   * We enter with non-exclusive mmap_sem (to exclude vma changes,
 --- a/mm/vmalloc.c
 +++ b/mm/vmalloc.c
-@@ -1245,6 +1245,7 @@ void unmap_kernel_range(unsigned long ad
+@@ -1246,6 +1246,7 @@ void unmap_kernel_range(unsigned long ad
  	vunmap_page_range(addr, end);
  	flush_tlb_kernel_range(addr, end);
  }
@@ -97,7 +97,7 @@
  
  int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages)
  {
-@@ -1360,6 +1361,7 @@ struct vm_struct *get_vm_area(unsigned l
+@@ -1361,6 +1362,7 @@ struct vm_struct *get_vm_area(unsigned l
  	return __get_vm_area_node(size, 1, flags, VMALLOC_START, VMALLOC_END,
  				-1, GFP_KERNEL, __builtin_return_address(0));
  }
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
index 8f64714f30..2c884dfa43 100644
--- a/target/linux/malta/Makefile
+++ b/target/linux/malta/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/orion/Makefile b/target/linux/orion/Makefile
index a8201f57ea..54e0c37ff2 100644
--- a/target/linux/orion/Makefile
+++ b/target/linux/orion/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
 CFLAGS=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/ppc40x/Makefile b/target/linux/ppc40x/Makefile
index ffd1b4489a..b2cb3a25a5 100644
--- a/target/linux/ppc40x/Makefile
+++ b/target/linux/ppc40x/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/ppc44x/Makefile b/target/linux/ppc44x/Makefile
index 8f65693dba..0de828259b 100644
--- a/target/linux/ppc44x/Makefile
+++ b/target/linux/ppc44x/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/realview/Makefile b/target/linux/realview/Makefile
index e697ba62df..e758ea77ea 100644
--- a/target/linux/realview/Makefile
+++ b/target/linux/realview/Makefile
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/uml/Makefile b/target/linux/uml/Makefile
index a91aac83b4..1f7b3fbcad 100644
--- a/target/linux/uml/Makefile
+++ b/target/linux/uml/Makefile
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 
-- 
cgit v1.2.3